The new Subversion.

Users who are viewing this thread

UghUghUgh

Squire
The best thing for the Crusaders would be using the recruiter (the one lone guy collecting up to fifty men) travelling through Europe to get the knights. That would throw the game off-balance I think, because it would take so much time for this guy and the men he recruited to go back to the holy land, even if he is smart enough to use the mediterranean sea. The optimum would be certain places where the orders historically had a house or convent or however you call their places.
If the player is expected to travel to the HRE to recruit knights for the teutonic order, you might as well have the player travel through Europe to collect templar and hospitaller knights. Maybe Rome could be used as a recruitment place for all sorts of crusaders.

Edit: I can't reproduce any CTD after fighting looters. It doesn't matter if I acces the item pool without a companion, with a companion, choose upgrading companions from the item pool, abandon items, or have the companions collect the loot. It doesn't matter what kind of bandits I attack, I don't get any error.
But the formations are still bugged when you have the men form ranks and order them to a certain place. The march back to where they came from unless you tell them to hold ground (F1+F4).
Constantly alt-tabing in and out causes CTDs, but that has to be expected. There is more to add to this messy post: Is it intentional to have a horsemen asigned to the infantry as an officer? If so, I like that idea.
 
Are you sure you're on todays revision Ugh?
Trigering the formation command(form square, form wedge, ect) will command them to reform on you're location. But the hold over there command should be working. Just tested it myself right now.
 

UghUghUgh

Squire
I used rev 6 this night. I updated now to rev 7 and will test it again. I just used the old rev 6 savegame for a battle and the infantry reforms where I stand, but I don't think that is intuitive. There should stick to the command they've been given, be it move or stand. Right now I have to add F1+F4 to stop them. Oh, and the "officer" is gone and I am sure it wasn't a companion on horseback in the wrong group.

Unfortunately, I still get CTDs in major field battles with 500 men battlesize, maxed out graphics on a Phenom II X4 965, 8 gig RAM, HD5850, Win7 64-bit. I'd love to hear a confirmation on that one.

After an abandoned siege I got these two messages with conflicting casualties and no Arab with the name "Sultan Mohammed ibn Nasr" was present.


Uploaded with ImageShack.us


Uploaded with ImageShack.us

One lord without body armour: Knyaz Bryachislav Vasilkovich from Novgorod
 
I've been trying to get the SVN to work, but I'm missing all the text that goes in the lower left hand corner. There's also unglodly lag between moving areas and even quicksaving makes the game freeze for a few seconds. And without text in the bottom I can't even see if it actually saved. It's making it downright unplayable.
 

Geroj

Sergeant at Arms
DrTomas said:
I bet you did not check this: http://forums.taleworlds.com/index.php/topic,131274.0.html

Yes i did

As i said i tried custom battle with 400 soldiers on max settings and no crash but on campaign battle it crashes even with 60 soldiers
I dont know why but it must be something with novgorod or snow scenes .... i try to test it more

---What about getting novgorod more cities, when they start they are in war with teutons and sweden so it is around 3000-4000 soldiers vs around 1000 novgorodians
 
Mithrur said:
Is it possible to use MBTweak with the Subversion 1257?
I tried and it always crashes at starting up.  :cry:

Too many little updates for him to keep up. After a 1.0 release, he will probably release support. for the mod again.
 

Sotuu

Sergeant
hmph next error with SVN and this time didnt continue with another update

virhe2.jpg
 

Sotuu

Sergeant
just gives same error arrakhis

Edit: ahh sorry didnt understand the errors msg before now. did the cleanup and now finished update  :grin:
 

Arrakhis

Knight
WB
Caeled said:
svn update worked fine, but now I get script errors

scripterrors.jpg
By caeled at 2011-05-14

its pretty random wait untill u bult a castle, its spams tehs creen untill u cant get any news, I havent tried the new version of castle building, I hope they fixed, aghhhh is there any cheat to --- nvm, my signature will be removed by ritterdumbatz if I ask
 
Caeled said:
svn update worked fine, but now I get script errors

scripterrors.jpg
By caeled at 2011-05-14

Was this from a new game after the update, or a continued game? If a continued game, were any factions destroyed prior to the update?
 

Caeled

Sergeant at Arms
it's from a new game with the new svn, but started 2 revisions before this one. I had not much time to play since then, so I guess there was no faction destroyed at all in this game.
 

ntb_15

Sergeant Knight
Caeled said:
it's from a new game with the new svn, but started 2 revisions before this one. I had not much time to play since then, so I guess there was no faction destroyed at all in this game.
Versions between revisions are generally not save-game compatible.
 
ntb_15 said:
Caeled said:
it's from a new game with the new svn, but started 2 revisions before this one. I had not much time to play since then, so I guess there was no faction destroyed at all in this game.
Versions between revisions are generally not save-game compatible.

DrTomas said it should be, but who knows.

I noticed more problems:

My battlemap is gone, as is the troop count.
In mod options, my troop speed was set to 23 instead 75(recomended).
By the looks of it, the script error that was posted above seems to be a very slow infinite loop. Faction id seems to tick up once each time it fires.

 
I need a savegame with the script error or you might wait quite a while for the script error to go away. I can't reproduce the error.

Battlemap was one of the few reasons why formations was bugged. So it had to go. I might reintroduce it later on, now that I know the direct couse of the issiue. But I personaly not a big fan of it, so I'm not in a big hurry. I'm more concern on stability right now.

UghUghUgh said:
I used rev 6 this night. I updated now to rev 7 and will test it again. I just used the old rev 6 savegame for a battle and the infantry reforms where I stand, but I don't think that is intuitive. There should stick to the command they've been given, be it move or stand. Right now I have to add F1+F4 to stop them. Oh, and the "officer" is gone and I am sure it wasn't a companion on horseback in the wrong group.
Officer was a glitch. I'm however would like to have a flag carrier for each group in the future.

UghUghUgh said:
Unfortunately, I still get CTDs in major field battles with 500 men battlesize, maxed out graphics on a Phenom II X4 965, 8 gig RAM, HD5850, Win7 64-bit. I'd love to hear a confirmation on that one.

Confirmed and possibly fixed. Lance breaking seemed to be the problem and I will disable it for now. But i'll try to fix it(lance breaking that is) when I have the time(which won't be anytime soon).

UghUghUgh said:
After an abandoned siege I got these two messages with conflicting casualties and no Arab with the name "Sultan Mohammed ibn Nasr" was present.


Uploaded with ImageShack.us


Uploaded with ImageShack.us

The message of casaulties when you retreat is suppose to be the loses you recieve while retreating. The causaulties report after the "mission" is the total amount of killed/wounded at the battle. So theres no error here

The Sultan is "booboo". Wrong string somewere is displayed/declared/assigned. Not a pririority, but I will try to hunt it down eventualy.

UghUghUgh said:
One lord without body armour: Knyaz Bryachislav Vasilkovich from Novgorod

I believe I fixed the reasons of naked lords. I also remaped the crusader troop faction recruitment, also introduced new merceneries for the balts and did some other things. Next revision will not be save comfortable, so will hold it off untill I do more things.
 

kila1221

Recruit
WB
hello new to the mod and forums but have been playing M&B:W since it came out.
A few bugs i have found, i have screens of. Will post asap but not sure where i should post bug reports for SVN. Here or if not Please tell me.
 
Top Bottom