Texture loading issue(?) with many mods

Users who are viewing this thread

Syrus127

Recruit
I've run into a strange problem after adding one more mod when already using a significant number of mods (40+).

Starting the game it looks like textures do not get loaded, for example MCM's mod options screen looks like this.
When I try to load a saved game, banners using modified textures next to the saves don't show correctly, missing the modified textures and the game crashes after a few seconds in the screen. If I do manage to load the save, for example via "Continue", the game crashes shortly after getting into the game - apparently upon seeing the bugged banner (I'm in a town, zoomed in enough that I don't see the banner unless I zoom out). It also crashes doing anything else that uses a modified texture.

Don't know what the actual exception is, because it crashes with just that lovely, helpful "The application faced a problem..."-window, even with BetterExceptionsWindow, and I have yet to figure out where else to get any information in regards to the crash.

The weird thing is, disabling even a single mod makes the problem go away, I tried it with several different mods.
(Interestingly, adding BetterExceptionsWindow does not cause the problem.)

Harmony (Steam)
ButterLib (Steam)
UIExtenderEx (Steam)
Mod Configuration Menu v5 (Steam)
Native
SandBox Core
CustomBatttle
Sandbox
StoryMode
Birth and Death Options
GlobalFaceOverhaul (Nexus)
Calradia Expanded (Nexus)
Open Source Armory (Nexus)
Open Source Saddlery (Nexus)
Open Source Weaponry (Nexus)
Calradia Expanded: Kingdoms (Nexus)
Better Smithing Continued (Nexus)
CalradiaCompanions (Nexus)
Companion Party Control (Nexus)
Crusty.WalkLikeALady (Nexus)
Improved Garrisons (Steam)
Marry Anyone (Steam)
Party Screen Enhacements (Nexus)
Realistic Weather (Nexus)
RTS Camera (Steam)
RTS Camera Command System (Steam)
True Relations (Nexus)
Useful Companions (Steam)
Xorberax's Legacy for v1.0.3 (Steam)
Detailed Character Creation (Steam)
Diplomacy (Steam)
MoreArenas (Steam)
CC's Banners (Steam)
Banner Editor (Nexus)
Bannerlord.TroopSorter (Nexus)
FamilyControl (Nexus)
DynaCulture (Steam)
Adjustable Leveling (Local/Steam)
Adjustable Bandits (Local/Steam)
Damage Modifiers (Local/Steam)
Piercing Projectiles (Local/Steam)
Siege Loadout (Nexus)
Null Hero Fix (Nexus)
Peasants (Nexus)
The Color of Profits (Nexus)
Highlight Better Items (Nexus)
Immersive Sergeant (Nexus)
Culture Switch - Companions (Steam)
Culture Switch - Vassals (Steam)
Character Manager (Steam)
Custom Patches (a local mod for testing stuff, but also stored on GitHub: link)
(All mods are using their latest available version; I have a few more mods which are not active.)

Could it be a load order issue that only shows with many mods for some reason?
Everything worked fine until I added my newest mod, Piercing Projectiles, but I'm certain that it is not the cause of the problem.
Maybe an issue due to loading such extensive mods early in the list?

Anyone got an idea what's going on here?


(Not posting this as a bug, because I have no idea whether this is game related or mod related.)
 
Top Bottom