WB [Terminée] VF de BannerPage 3.x

Users who are viewing this thread

Daneel53

Sergeant Knight at Arms
Bonjour,

GorillaGuerrilla a sorti le 2 octobre 2022 une version 3.0 de son mod BannerPage, on peut la prendre sur Moddb ici :
https://www.moddb.com/mods/bannerpage/downloads/bannerpage-30

Comme il l'indique dans la page de son mod, celui-ci est désormais directement localisé en français, sauf que...
En réalité, le français intégré à cette version est constitué de ma VF de la version 2.2 de mars 2021 (que je lui avais proposé d'intégrer à sa 2.2), VF sur laquelle il a traduit quelques nouvelles lignes grâce à Google Trad et laissé d'autres en anglais. Donc, de fait le VF intégrée à la 3.0 est partiellement fausse et incomplète.

J'ai réalisé la VF intégrale de BannerPage 3.0, VF en date du 11 octobre 2022. Vous pouvez la prendre avec ce lien : https://bit.ly/3TihtTQ

Je l'ai transmise à GorillaGuerrilla (qui m'a informé par mail de cette nouvelle version après la sortie de sa version 3.0), mais elle ne sera pas intégrée officiellement tant qu'il n'aura pas sorti un patch, donc je préfère pour l'instant vous la mettre en ligne en attendant ce patch.
Par rapport à la VF que j'ai produite pour la version 2.2, l'auteur m'a écouté puisqu'il a supprimé les doublons dans menus.txt et qu'il a changé sa fonte pour qu'il n'y ait plus de problème d'affichage avec les caractères accentués français. La VF est donc simplement constituée des fichiers .csv, ce qui facilite l'installation.

Pour l'instant il reste un problème avec deux entrées de l'aide en jeu (la page qui s'appelle Concepts habituellement) car deux textes anglais sont trop longs et les textes étrangers sont coupés. Il faut attendre que l'auteur découpe ses deux entrées pour que ce bug disparaisse.
Je vous ferai savoir quand ce bug sera corrigé et quand le patch contenant la VF définitive sera sorti par GorillaGuerrilla.

Bon jeu ! :xf-smile:

Édit du 3 juin 2024
Le lien ci-dessus mène désormais vers la VF de la version 3.2 de BannerPage qui est la version qui doit être jouée et non plus la 3.0.
 
Last edited:
Le mod a effectivement été conçu pour être une version améliorée de Native, incluant des mods comme Diplomacy, PBOD et Freelancer, de nouveaux rôles comme chasseur ou chef de bandits et plein d'autres choses ajoutées spécifiquement par l'auteur.
Un mod à essayer, sans aucun doute. :xf-smile:
 
Salut !

Je viens juste de voir qu'un patch 3.1 pour Banner Page est sorti sur Moddb le 6 décembre 2022.
J'ai regardé le contenu du patch et c'est bien désormais ma VF pour 3.0 qui est distribuée avec le mod. Donc tout va bien de ce côté là, le téléchargement et l'installation de la VF n'est plus utile avec ce patch.

Quand j'aurai le temps, je jetterai un coup d'oeil pour voir s'il n'a pas modifié des textes avec son patch, ou s'il a coupé les deux pages de Concepts qui posaient problème.
 
Salut !

Je viens juste de voir qu'un patch 3.1 pour Banner Page est sorti sur Moddb le 6 décembre 2022.
J'ai regardé le contenu du patch et c'est bien désormais ma VF pour 3.0 qui est distribuée avec le mod. Donc tout va bien de ce côté là, le téléchargement et l'installation de la VF n'est plus utile avec ce patch.

Quand j'aurai le temps, je jetterai un coup d'oeil pour voir s'il n'a pas modifié des textes avec son patch, ou s'il a coupé les deux pages de Concepts qui posaient problème.
Hey ! Que donne ton analyse ?

J'ai vu un patch 3.2 sur Moddb daté du 25 août 2023. D'après le descriptif, c'est juste pour corriger un bug de la fameuse promotion d'un "simple soldat" en compagnon. Je suis entrain de l'essayer. J'ai vu plusieurs problèmes de textes et messages d'erreurs. Je t'envoie les captures d'écrans + ma sauvegarde. Certains messages d'erreurs proviennent peut-être plutôt du mod que de la traduction ? Je te laisse juger...
 
Last edited:
Salut Alfe !

Je serais bien en peine de répondre à ta question. D'abord parce que je ne suis pas actuellement sur mon PC habituel, donc je n'ai pas sous la main les dossiers contenant mes traductions de mods de Warband et il m'est impossible de voir si j'ai fait la vérif en question. Mais surtout parce que je soupçonne que si je ne suis pas revenu ici donner des nouvelles, c'est sans doute parce que j'étais plongé dans autre chose (probablement la traduction de DFU à cette époque) et que j'ai par la suite oublié de faire cette vérification.

J'ai bien reçu ton mail avec l'archive en pièce jointe. Du coup je passerai directement au patch 3.2 pour comparer avec les textes de la 3.0. Encore une chose à ajouter à ma ToDoList, ce qui fait que je me retrouve avec trois sujets brûlants sur le feu. Les deux prochaines semaines s'annoncent chargées !

Si je ne donne pas de nouvelles ici d'ici à deux semaines, n'hésites pas à me sonner à nouveau pour me rappeler à l'ordre. :xf-wink:

Nota : Les erreurs de script affichées en rouge ne viennent pas de la traduction mais d'un problème lié au mod lui-même ou à un Script Enhancer quelconque, WSE ou WSE2 par exemple qu'il ne faut pas utiliser avec ce mod comme expliqué dans le descriptif sur Moddb.
 
Salut Alfe !

Je serais bien en peine de répondre à ta question. D'abord parce que je ne suis pas actuellement sur mon PC habituel, donc je n'ai pas sous la main les dossiers contenant mes traductions de mods de Warband et il m'est impossible de voir si j'ai fait la vérif en question. Mais surtout parce que je soupçonne que si je ne suis pas revenu ici donner des nouvelles, c'est sans doute parce que j'étais plongé dans autre chose (probablement la traduction de DFU à cette époque) et que j'ai par la suite oublié de faire cette vérification.

J'ai bien reçu ton mail avec l'archive en pièce jointe. Du coup je passerai directement au patch 3.2 pour comparer avec les textes de la 3.0. Encore une chose à ajouter à ma ToDoList, ce qui fait que je me retrouve avec trois sujets brûlants sur le feu. Les deux prochaines semaines s'annoncent chargées !

Si je ne donne pas de nouvelles ici d'ici à deux semaines, n'hésites pas à me sonner à nouveau pour me rappeler à l'ordre. :xf-wink:

Nota : Les erreurs de script affichées en rouge ne viennent pas de la traduction mais d'un problème lié au mod lui-même ou à un Script Enhancer quelconque, WSE ou WSE2 par exemple qu'il ne faut pas utiliser avec ce mod comme expliqué dans le descriptif sur Moddb.
Ok, ça marche, je me suis noté de te relancer dans 2 - 3 semaines si besoin 👍

J'ignorais ce qu'est un Script Enhancer, y compris WSE et WSE2 ?! Je viens tout juste de me renseigner. J'en déduis que le problème vient du mod lui-même, mais un autre retour serait bien apprécié (histoire de voir s'il n'y a que chez moi ce problème 😅).

Si je décide d'utiliser WSE2 (sur Steam), il suffit que je me souvienne de lancer Warband avec le .exe d'origine pour jouer à BannerPage ? Il indique avoir corrigé quelques bugs du moteur de
Warband grâce à WSE2, ça peut m'intéresser, même si je ne me souviens pas d'avoir vu de bug 🤔

DFU c'est Daggerfall Unity ?

Merci pour tous @Daneel53 !!! 😁
 
Je n'utilise jamais WSE ou WSE2 car je n'ai pas besoin de passer par là pour tester mes trads. Mais, oui, il corrige certains problèmes du moteur et surtout ajoute des scripts qui permettent d'en étendre les fonctionnalités. Je ne connais pas les raisons, mais ce sont souvent ces scripts additionnels qui mettent la cagouille quand le mod qui tourne ne les a pas prévus. On lit d'ailleurs souvent que les auteurs des mods doivent modifier leur code pour que leur mod devienne compatible de WSE, ce qui est assez paradoxal pour un utilitaire qui normalement ne devrait qu'ajouter des scripts et non modifier ceux qui existent.

Ceci dit, il se peut aussi que ces erreurs proviennent d'une erreur de codage dans le mod sans que WSE soit utilisé, auquel cas toute le monde doit voir ces erreurs en lançant le mod. Je verrai ce qu'il en est quand je lancerai BannerPage 3.2 la semaine prochaine.

Et, oui, DFU = Daggerfall Unity, dont nous avons terminé la traduction française à 100 % il y a environ un an. En ce moment je suis en train de travailler à lui greffer un module de grammaire dans le style de ce que TaleWorlds a fait dans Bannerlord en introduisant des tokens de grammaire dans les textes de la traduction et un processeur de traitement grammatical dans le code. Je suis en train de tester ça activement et j'espère pouvoir introduire ce module de grammaire dans la prochaine version de DFU, la 1.2. :xf-smile:
 
Last edited:
J'ai eu le temps d'installer BannerPage 3.2 sur mon portable et je ne rencontre pas les erreurs en rouge que tu m'as envoyées (voir mon mail). Je soupçonne un problème d'installation chez toi, à confirmer...
 
Je viens de remettre les mains sur le clavier de mon PC et je confirme que je n'avais rien fait sur la 3.1.
Je vais donc traiter directement la 3.2.

Après comparaison des fichiers anglais, seul le fichier troops a évolué et les modifs ne concernent que des PNJ dont les titres ont été inversés deux à deux (les équivalents de comte et baron).
Il faudra donc générer une VF 3.2 pour prendre en compte ces modifications mais, indépendamment de ces problèmes de titres, la VF livrée avec le jeu est bien la dernière que j'avais produite et elle est complète.
 
Last edited:
La VF en date du 6 juin 2024 pour BannerPage 3.2 a été mise en ligne.
Elle se prend avec le même lien que la 3.0 car cette VF remplace la précédente : https://bit.ly/3TihtTQ

Bon jeu !
Bonjour @Daneel53, merci beaucoup 😊

Nous sommes le 03 juin 2024 aujourd'hui, pas encore le 06 juin 2024 comme indiqué dans ton post. Une petite coquille doit s'être glissé ans la date de ta VF ?

Très bonne semaine à toi ! 👍
 
J'ai eu le temps d'installer BannerPage 3.2 sur mon portable et je ne rencontre pas les erreurs en rouge que tu m'as envoyées (voir mon mail). Je soupçonne un problème d'installation chez toi, à confirmer...
Bonjour @Daneel53

J'ai refait une installation de Warband et de BannerPage 3.0 puis patch 3.1 puis patch 3.2.

Petits problèmes de VF: à la création du portrait de son personnage, certains paramètres sont VO.

Et maintenant, c'est en arrivant au bout de la création qu'un message en rouge s'affiche, rendant inefficace le clic sur "Continuer". Je n'ai toujours pas utilisé WSE, j'ai juste augmenté la taille de bataille à 300 via le dossier "EXTRAS" en suivant bien les instructions en VO. J'ai appliqué le patch 4GB sur l'exe Warband.

Je t'envoie les captures d'écrans via mail.
Une solution ?

Merci d'avance :wink:
Cordialemement
 
Il y a toujours un gros problème d'installation chez toi.

Tout d'abord les textes "Lower lip" et "Upper lip" sont bel et bien traduits dans ma VF (fichier skins.csv, lignes 6 et 7) et sont affichés en jeu en français chez moi.

Mais, surtout, le texte affiché dans ta capture d'écran en fin de création n'existe pas dans BannerPage (et personnellement je ne l'ai pas quand je crée une nouvelle partie) mais c'est une phrase qui existe dans le fichier game_menus.csv de nombreux autres mods de Warband comme Perisno ou Warsword.

Si tu détruis totalement le dossier BannerPage de Modules et refais l'installation correctement dans un dossier BannerPage tout neuf, ces problèmes devraient disparaître.
 
Last edited:
Back
Top Bottom