Modded System.IndexOutOfRangeException

Users who are viewing this thread

Version number
Yes, I used mods.


Summary: I keep getting an error after about day 187. It's the same thing, no matter what I'm doing in the game itself.
How to Reproduce: I've been doing all sorts of activities in the game to see if it won't trigger but no matter what I do, the crash begins once I try to load a save after a certain date, day 187.
Have you used cheats and if so which: No, just mods.
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: nVidia GEForce GTX 1060
GPU Driver Version: ///
RAM: 16gb
Storage Device (HDD/SSD): SSD

I cannot post a link to my full crash report due to the newness of my account, but the main exception list is as follows:

Exception information
Type: System.IndexOutOfRangeException
Message: Index was outside the bounds of the array.
Source: TaleWorlds.CampaignSystem
  1. at int TaleWorlds.CampaignSystem.Roster.TroopRoster.AddToCountsAtIndex(int index, int countChange, int woundedCountChange, int xpChange, bool removeDepleted)
  2. at void TaleWorlds.CampaignSystem.Roster.TroopRoster.RemoveTroop(CharacterObject troop, int numberToRemove, UniqueTroopDescriptor troopSeed, int xp)
  3. at void TaleWorlds.CampaignSystem.Hero.AfterLoad()
  4. at void TaleWorlds.CampaignSystem.CampaignObjectManager+CampaignObjectType.AfterLoad()
  5. at void TaleWorlds.CampaignSystem.CampaignObjectManager.AfterLoad()
  6. at void TaleWorlds.CampaignSystem.Campaign.OnGameLoaded(CampaignGameStarter starter)
  7. at void TaleWorlds.CampaignSystem.Campaign.DoLoadingForGameType(GameTypeLoadingStates gameTypeLoadingState, out GameTypeLoadingStates nextState)
  8. at void StoryMode.CampaignStoryMode.DoLoadingForGameType(GameTypeLoadingStates gameTypeLoadingState, out GameTypeLoadingStates nextState)
  9. at bool TaleWorlds.Core.GameType.DoLoadingForGameType()
  10. at void SandBox.SandBoxGameManager.DoLoadingForGameManager(GameManagerLoadingSteps gameManagerLoadingStep, out GameManagerLoadingSteps nextStep)
  11. at bool TaleWorlds.Core.GameManagerBase.DoLoadingForGameManager()
  12. at void TaleWorlds.MountAndBlade.GameLoadingState.OnTick(float dt)
  13. at void TaleWorlds.Core.GameStateManager.OnTick(float dt)
  14. at void TaleWorlds.MountAndBlade.Module.OnApplicationTick_Patch1(Module this, float dt)

What's happening? This is really dampening what is otherwise one of the most fun gaming experiences I've had in years. Anyone know what this error is and how to fix it? It's just weird because everything works fine up until day 187, and then after that, the game file will stop loading correctly. I have some older save files before day 187 that load fine still.

Here is a list of my active mods:


Crash report ID:

Also just confirming that I have already verified the files on Steam a couple times, and I've also deactivated all mods and tried to load the files once they begin to give me this error and they still fail to load. It's weird. Everything runs fine until about day 187, and then all of a sudden I get crashes when trying to load a file.
Last edited:


Community Support
Community Support
Hey, we do not offer support for the mods or modded games. Can you try to reproduce the issue on a new campaign after manually removing all the mod files and verifying the integrity of the game files. If the issue is persistent on a new, unmodded campaign please let me know.


I understand, thank you for the reply. Game runs great without mods, and you guys have done a fantastic job overall. That being said... I have put too much time into this modded save and if anyone has any advice, I would greatly appreciate it.
Top Bottom