Stuttering in battles above 200 battle size.

Users who are viewing this thread

Kitai

Recruit
Hi,

I don't have any performance issues in any other area of warband than the battles. When there are more than roughly 200 units there is a stutter about every half second when I am in battles. This is despite the fps being technically fine. It can be sitting at 60 fps and this is still happening, so it feels like 10-15 fps or so. It's playable but not if I want to do anything other than sit still and wait until the battle finishes, though the stuttering stops when enough units have died.
This doesn't happen in native, VC and a few mods (1257ad, Perisno, L'Aigle). Runs completely smooth in these and I can have hundreds of units.

I understand that the engine for this game is quite old and has it's limitations but I have seen many people talk about having large battles in bigger mods like Pendor and there are plenty of Youtubers who somehow manage to maintain a smooth framerate in bigger battles (300+) in their videos. I don't understand what they have done to get their game like this. No stuttering at all. My system should be able to run this game, even with the limitations in how it uses your tech.

I've barely ever seen anyone report this issue but plenty of other ones related to performance with larger battle sizes. I've tried all the fixes that I have seen. (Setting CPU priority, force single threading, lowering settings, render buffer size, downgrading drivers etc.)

Did/does anyone have this issue and if you managed to fix it how so? I've seen people have larger battles in mods so I know it's possible, I just want to know how.
Thank you.
 
If you are sure that your PC is able to run Warband smoothly on highest settings, maybe it is a case of some unoptimized mods which cannot handle large battles. You must bear in mind that not every mod has been brought to later stages of Warband development with new engine possibilities and stuff. Try WSE/ WSE2 to see if the problem still persists; 'WSE' stands for Warband Script Enhancer and has two main versions; each allows to make full use of hardware, as it enables the engine to run in all cores and generally optimizes it.
 

Kitai

Recruit
If you are sure that your PC is able to run Warband smoothly on highest settings, maybe it is a case of some unoptimized mods which cannot handle large battles. You must bear in mind that not every mod has been brought to later stages of Warband development with new engine possibilities and stuff. Try WSE/ WSE2 to see if the problem still persists; 'WSE' stands for Warband Script Enhancer and has two main versions; each allows to make full use of hardware, as it enables the engine to run in all cores and generally optimizes it.
It still happens when I run the game through WSE unfortunately.
 
It still happens when I run the game through WSE unfortunately.
Maybe it is as I mentioned, some mods may be unoptimized. There is not really anything you can do if you do not want to tamper with the source code of the mods of your choice.
 
Top Bottom