Strange stuff with ATI

Currently viewing this thread:

Hello , dear Taleworlds.
I am using Athlon XP at 2200 mhz frequency , 1GB of DDR 400 ram , and a (i think) the most probelmatic part : A graphic card called Ati HD 4650 (512mb). using Windows XP SP3 , ATI CCC 12.3 , Directs n'such stuff all updated. And now the problem : when i run a Mount and Blade with DX9 , the first bandit in town : No prolemo , except that a game has like little milisecond freezes , that is not so bad. When reaching merchant house , the game says it have from 70FPS suddently 11FPS , and the game is unbelieveably scrolling. When i get thru this , and get to the map , when i move with map , game stop reacting : Map got somehow weirdly ..... (Dont know how to describe it) .. i mean it just get fu***d up textures and at some places is map somehow.. scrolling (I mean that when you have fatal error in windows , so you can do a sea , this is something like it) and it doesnt react to menu (Map still showing , menu not) and not to move commands not reacting too. Soo.... At DX7 its almost same , except that a textures go black and i see a torches at merchant house (And hair'n beard) and map same.    Using 1024x768 , textures max... pretty much everythnig max except grass'n trees. Game is at 1.143 .. or somehow.. Its warband.
 
It isn't driver issue , i am sure with it , i have reinstalled windows twice :smile: ill try reinstall game. (It may be a problem , cuz i was copiing it from drive to drive because slow internet and lazyness to download it again. (I had a completly differend PC , a intel with intergrated graphics)
 
There haven't been any reports of Warband doing this poorly on recent ATI drivers. Back in the mid 10.xs there were definite problems, but I've not seen anything like this in the past year or so...hence the possibility that there's an installation problem.
 
Nope , reinstalled game and managed to get Napoleonic wars : The game looks somehow ok , but most of textures missing (Hat , normal floor for example stairs is showing) and the end of map .. sky box ... or how it is called does same stuff like windows at epic error.
 

Treebeard

Knight at Arms
M&BWB
If you find the file named game_variables.txt (in Native and other mods), you can comment out the first lines (buffer_size lines):

# Initial Buffer_sizes
# Modders may adjust these large enough so that the game will not need to restore
# buffers during the game. However keeping them excessively large will reduce performance in most systems.
#Buffer_sizes (if smaller than 65535, this also represents the maximum vertex count for a corresponding mesh)
#new_buffer_size_dx7_regular_ffp_static  = 262144
#new_buffer_size_dx7_regular_ffp_dynamic = 262144

#new_buffer_size_regular_ffp_static =  32768
#new_buffer_size_regular_ffp_dynamic    =  32768
#new_buffer_size_regular_static          = 131072
#new_buffer_size_regular_dynamic        =  65536
#new_buffer_size_skinning_static        = 131072
#new_buffer_size_skinning_dynamic        =  65536
#new_buffer_size_normal_map_static      = 131072
#new_buffer_size_normal_map_dynamic      =  65536
#new_buffer_size_normal_map_skinning_static  = 131072
#new_buffer_size_normal_map_skinning_dynamic =  65536

That may alleviate the issues.
Also, ATI drivers 10.3 to 10.6 should work best with Warband (at least for 4000, 5000 series -- 10.3 to 10.6 should have no graphics corruption normally).
 
Greetings sir Treebeard , i shall try 10.6 drivers + your tweak of game_variables and post my results , btw , thx for trying help me. (btw , Napoleonic wars looks awesome)

oh , yeah , and it seems like version i used was outdated (of MaB)
 

xenoargh

Grandmaster Knight
With 1GB of RAM, you're going to be hard-pressed to keep even Native running.  That's almost certainly the core problem here; this game's really memory hungry and it is very unstable if you don't have enough RAM available.

Lower texture sizes to minimum, shut all music and sounds OFF and do as Treebeard suggested; that will cut memory use to the bare minimums and if that makes it stable, try turning sounds back on, but without variation, etc., see how far you can go before it goes off the rails again.
 
I dont know what were you smoking , but i was playing PoP on low settings but blood / sound all on with 100 at once without problem.
 
Well , reinstalled MaB , get that drivers , remade config .... On Dx9 its ok for a while , but after around 2-3 minutes game ****s up like before. At DX7 about in 30 secs all characters lose heads , weapons , hats , all objects like fences disappear. The **** is this.. And for some reasons i have also framerate drops , like i have 80-120 fps , and blam , it turns for a second to 10-20 fps.
 
Hello , let me do some Necromancy.
Well , i've actually had solved the problem :smile:
Core of problem was the drivers.... i've always had set in CCC performance settings (You know , mipmap details'n stuff)
Setting it to normal magically solves whole problem and i rock Warband no problem :smile:
I hope this will actually help anybody , because this problem made game unplayable ..
So , would be good to spread this message to persons with same problems :wink:
 
Top Bottom