Strange fps decrease...

Users who are viewing this thread


I tried the 2nd solution, didn't work.

And I have no clue how to check the BIOS for CPU throttling, (ik how to get into the bios etc etc, just not how to check if the CPU is throttling)

Also, another thing which has never happened to me on the game:

Every time I try to change any major setting in the video options, like HDR or shadows etc, it just crashes to desktop but the change is made already when I re-enter the game, its really annoying.

Same if I try to tab out or even go windowed mode for a bit, it just CTDs...


Sergeant Knight
I've got a fix for ya man. Also had one of the Nvidia GPUs and experianced the same problem.

Try downgrading your GPU Drivers to some older ones - possibly as old as possible, just perform a clean install for some old drivers.

It was for GTX 970 and 980 - I guess this may be the case.

Also, a fix for one of the 970 users from steam community:
so herpy derpy dooo, this fixed it, even though with a gtx 460 i never noticed stuttering fps..
changes as follows

warband launcher >> vid settings >> start in windowed mode un-checked

also (and i dont know if this helped, it doesnt make sense to me because my monitor only does 60hz anyway) ---- i changed max fps in the box from 60 to 120 (just to see)

BAM no more dumb ♥♥♥♥ery
i even changed most of the other settings back

smoothing = on (from off)
AA = on
force vert sync = on

no problems.... da♥♥♥♥

Also2: Check if you're not running Wabrand using integrated GPU. Simply by dxdiag.


Sergeant Knight
I have been looking this thread because I have similar problems. Finally found a fix that fixes most of the lag.

Open game folder -> right click mb_warband -> open properties -> compatibility -> run compatibility with Windows xp

Also check "run game as admin"

My default setting was Windows 8 and that caused a lot of lag. This is also why I didn't have lags with other games but only Warband.

Edit: you should also check this:
Top Bottom