In Progress Starting the game from Steam doesn't work. Launcher dissapears and nothing happens.

Users who are viewing this thread

Version number
e1.6.1
Branch
Main
Modded/unmodded
Yes, but I removed mods.

Nhod

Recruit
When i click on the steam icon it won't launch the game, all that happens is that the icon appears for a few seconds then goes away without any crash report happening. I CAN launch the game from EXE but i want to use some simple armor mods which you can't do from EXE.

I have tried more than 20 different fixes now and even tried fixing things in Windows. I've gone through all of the fixes you have posted here earlier and it's the same problem and it has been like this for several months. I'm not really interested in doing a windows reinstall just for this and even though i've done a complete clean reinstall of the game it doesn't work.

This is a problem loads of people have going by the google results. There is something wrong that nothing can fix that i can find and i've spent hours upon hours trying to fix this.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you tried a clean install before?
Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 

Nhod

Recruit
I've tried that before but there is no " Delete Local Content" option on my steam. There's only uninstall which i did and then deleted files in all those places like you suggested. Still the same.

Edit: I'm trying it again to see if i missed something, will update on the result.
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you try deleting the games ProgramData folder and try again? Please note that programdata folder is a hidden folder.
 

Nhod

Recruit
I did a complete clean reinstall and deleted bannerlords programdata, the only change is that the launcher doesn't stop within 2 seconds it takes like 5-7 seconds before it closes now.
 

Nhod

Recruit
I don't know if this helps but, i tried the e1.3.0 version and the launcher worked without a problem. I then tried the e1.6.0 version and the launcher did not work again. So something changed between those version that is stopping it from working.

Edit: I'm checking all the versions to check which version makes it not work. So far e1.4.3 also works.
 
Last edited:

Nhod

Recruit
Everything works until the e1.5.6 version and then it stops working. So e1.5.6 is the version who broke the launcher for me.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Have you used this workaround?

‘Launcher not Launching’ / Game is not launching Workarounds​

If you experiencing any issues with the launcher, you can try the workarounds below to fix it:
  • The first thing to do when experiencing any issue with the game is verifying the game files. After an update, there is always a chance of some of the game files being corrupted or missing. Doing this will verify that the game files are installed correctly. You can also check our guide regarding this here.
  • Deleting the configs folder of the game located in the Documents folder. Please keep in mind that this will also delete your saved options of the game. Don’t forget to back up the files if you don’t want to lose them. (C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs)
  • If you have installed a mod called Fixed Launcher in the past, you need to make sure that you have deleted its files. These files can block the launcher from launching. The files of the aforementioned mod.
  • Check your Windows Defender settings for Ransomware Protection. You should add Bannerlord to the list under the Controlled Folder Access. To do that:
  • - Open Windows Defender Security Center.
    - Click on Virus & threat protection.
    - Click the Virus & threat protection settings option.
    - Under "Controlled folder access," click the Allow an app through the Controlled folder access link.
    - Click the Add an allowed app button to add Bannerlord.
  • If none of the workarounds above helped you, you can try to launch the game via the TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder below:
    ...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
 

Nhod

Recruit
Like i said earlier i have tried all those things before but i tried them again now to make sure. It still does not work.
 

Nhod

Recruit
The fact that the launcher works fine before e1.5.6 makes me believe that it has nothing to do with my PC or my setup
 

Nhod

Recruit
I can start the game from the singleplayer.exe file but i would like to use some simple mods which you can't do without the "real" launcher.
 

Cynrig1

Recruit
Hi I am having the same problem, deleted the files, uninstalled the game, and reinstalled, Game will not play
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you guys try deleting the LauncherData.xml file and try launching again? It is located in: C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs
 
Top Bottom