Resolved SP/MP - Game Crash - 3d3_device_context

Users who are viewing this thread

Version number
e1.72.316994
Branch
Main
Modded/unmodded
No, I didn't use any mods.

bjergboi

Recruit
Summary: Hello, I am trying to play singleplayer (it is doing the same thing on MP too) and I am getting this error message after few minutes ingame (screen bellow)
I tried everything I found on the internet.

How to Reproduce: I don't have any idea how to reproduce it, it happens few minutes after the lunch ingame.

Have you used cheats and if so which: No

Scene Name (if related): -
Media (Screenshots & Video):
I cannot put screenshots here as I am new here. So here is the text of the error message:

ERROR
d3d_device_context_- Map at rglGPU_device::lock_texture_Failed!
Instance of the GPU was stopped. With GetDeviceRemovedReason..

(translated from my language to eng).

Thank you.

Computer Specs:
MB: ASUS ROG STRIX B550-F GAMING
CPU: Ryzen 9 5900X
COOL: Arctic Liquid Freezer II 360
RAM: G.SKILL 64GB KIT DDR4 3600MHz CL16 Trident Z RGB Neo
GPU: MSI GeForce RTX 3070 GAMING X TRIO
PSU: EVGA SuperNOVA 750 G+
HDD: WD Blue 1 TB 7200
SSD: WD Blue 500 GB
M2.SSD: Kingston KC1000 480 GB
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
This crash is a GPU crash. Which is different from the other crashes that can be caused by gameplay actions. While we are still investigating the issue there is not a definite fix that we can offer on this issue at the moment. You can try the workaround below but please note that it is not a solid fix. Thanks for reporting. Sorry for any inconvenience.

A possible fix for RGLGPU_DEVICE::LOCK_TEXTURE Crash
If you are crashing in the middle of the game with the “RGLGPU_DEVICE::LOCK_TEXTURE” error, you can try the workaround below to fix it:
  • Expanding the swap size on your hard disk. You can find more info regarding this here.
 

bjergboi

Recruit
Hi MArdA,

I already did this workaround and it did not help at all :sad:.

I tried to underclock my GPU a bit - didn't help
I tried to overclock my GPU a bit - it helped and the game now is stable.

Even tho I have 3070.

Thank you.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Glad to hear at least you found a solution. Sadly we can't offer any more support on this issue.
 
Just found the "real" after few month (was hoping the full release will solve the problem but no...)

This solution worked for me (Also have a 3070)

- I launched the game in multiplayer (worked for me)
- Set all setting to "low"
- Quit the game
- Launch the game in Single Player
- Put video setting on very high again
- Deactivate "Screen Space Reflection"

Totaly worked for me
 
Top Bottom