Resolved Scene Editor Some nodes won't render terrain paint

Users who are viewing this thread

Version number
Summary: For some reason only some of the nodes in my scene are rendering all terrain layers while the others are only rendering the base layer. After changing the water level, removing layers, and changing overall terrain height, the problem still persists and I don't know what else to check. For reference the scene is 16x16 nodes, what I'm pretty sure is the maximum number of nodes allowed. Also I would upload images for proof, but my urls keep getting rejected. Also mod is only there to save scenes in.
How to Reproduce
: Launch test mission from editor.
Specific Tool: Scene Editor
Media (Screenshots & Video):
Computer Specs:
OS: Windows
GPU: Sapphire Radeon R9 290
GPU Driver Version: 20.4.2
CPU: Intel i5-4690K
Motherboard: MSI Gamin G45 Z97
Storage Device (HDD/SSD): SSD

MArdA TaleWorlds

Community Support & Localization
Community Support
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
[Update] So I exported the heightmap from the scene I've been working on into a blank scene to start over, redid all the terrain layers, except for the roads, and still the problem persists. This video should help explain what's happening.

Video description:

Something weird is going on with the terrain layers. The order from the water to the hilltops should be soil, gravel, grass, with rock at steep inclines (30-90 degrees). The layers display correctly in the editor in edit mode, but when I launch the scene as a test mission, the gravel and grass layers are switched, and most nodes only render the base layer. This is a brand new scene, 16x16 nodes, point map resolution and height map resolution of 128, height map import from 16-bit png. Can't figure this out for the life of me.
[Update] Fixed (for now). Not sure exactly what fixed this problem , so I'll list what I think might have fixed it.
1.) Most likely an update fixed the issue. I don't think there are patch notes for the scene editor so I can't know for sure, but that TaleWorlds fixed it themselves is most likely.
2.) Under the ''Shaded" dropdown menu on the main scene editor screen there are a few debug operations. I clicked through a few of them and after doing so, the test missions now properly render terrain layers. These should just indicate a problem, but maybe they fix problems too.
3.) I've gotten lucky somehow and tomorrow when I load the scene the problem will come back for unknown reasons.

Whatever fixed it I'm just glad that now I can run the test missions without my eyes bleeding. Here's proof that at least for me the bug is fixed:


MArdA TaleWorlds

Community Support & Localization
Community Support
I've been informed that this bug is fixed and will be sent to the game with one of the latest patches. Can you check if you still experience this issue? I've gone forwarded and marked the topic as resolved unless you state otherwise.
Thanks for reporting and sorry for any inconvenience!
Top Bottom