• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved smithing UI glitch

Users who are viewing this thread

Version number
1.6.0
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

gviktor

Recruit
Summary: After game updated 1.6.0 the smithing screen became totally messy.
How to Reproduce:
Have you used cheats and if so which: No.
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Microsoft Windows 10 Professional (x64) Build 19042.870
GPU: AMD Radeon RX 570
GPU Driver Version:
Driver Version: 21.4.1 After Update
CPU: Ryzen 3 1200 (no overclock)
RAM: KINGSTON KHX2666C16/8G DDR4-2666 / PC4-21300 (2 * 8 GB Dual Channel)
Motherboard: ASRock B450 Pro4
Storage Device (HDD/SSD): KINGSTON SA2000M8500G 500 GB NVME SSD

What I tried to resolve the issue:
-Restart game and PC
-Verify local game files on Steam.
-Update my VGA driver
-Try smithing on new character.

None have worked.

My smithing screen looking like this:

saEXJ.png
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you try deleting the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders and verifying your game files?
 

gviktor

Recruit
Can you try deleting the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders and verifying your game files?
Unfortunately, it did not work. :sad: The steam redownloaded those files but it did not change anything. The files were not corrupted.
 

gviktor

Recruit
I finally solved the issue. I try redownload more and more files that seems insignificant in this case. I don't know which one but the glitch disappeared. So probably it was a corrupted file that the steam could not see problematic. All in all thanks for the help.
 

Rocksummit

Recruit
I've been having the same issue allthough my text for weapon information is garbled as well. I never used mods.
For a while the problem dissappeared on my run but now came back again. I tried verifying my files on steam and installed the latest nvidia driver and now the problem dissappeared. Not sure which of the two that made the difference.
 
Top Bottom