Need More Info Scene Editor Shaders compile everytime i load my map?

Currently viewing this thread:

Klassix

Recruit
Summary: As requested from gkx I am opening this report.

I am experiencing long load screen times every time I test my map in Custom Battle mode. Native TW maps take about 2 seconds, while mine is going over 45. gkx explained there might be a bug with shader compiling. I do have had a lot of shader issues(blue terrain, tiles covered in first terrain layer only) which required me to save the map to a new file pretty often.
Currently, there are no spawnpoints set by me, and navmesh is also not available. Just for your information.

How to Reproduce: Load my map I have send you in a Custom Battle.

Computer Specs:
OS: Win10 Pro
GPU: GTX 1080
GPU Driver Version: 457.30
CPU: i5 9600KF 3,7Ghz
RAM: 32GB 3200Mhz DDR4
Motherboard: ASUS TUF Z390-PRO Gaming
Storage Device (HDD/SSD): Samsung MZ-V7E1T0BW 970 EVO 1 TB NVMe M.2
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Klassix

Recruit
After a fresh windows install my map now loads as fast as the native maps. Something was wrong at my end. You may consider this problem solved.
EDIT: After I have experienced the blue terrain layer issue once again, I have only changed one layer, I saved the scene as new file and then the long loading times have returned, for the new file. Game or Editor issue?

Things I have tried without success:
-Clear Shadercache
-Save as new Scene
-Save as new Scene and tried a new name in custom_battle_scenes.xml
-while in editor, deleted terrain_ed.bin, saved to generate a new one, retry.
 
Last edited:
Top Bottom