Unresolved Serial Key isn't working

Users who are viewing this thread


as in the title my serial key isn't activating the game i bought mount and blade warband, Napoleonic and Viking in a bundle on steam and played without having to use the keys provided when i start running it. i downloaded Phantasy calradia and it worked without the key, but i just downloaded warsword conquest Southlands edition and now i need to use the serial keys to activate the game but they aren't working.
does anyone know why?
also i tried buying the game through tale worlds but that key didn't work either.
If it helps i just downloaded the WSE to run warsword along with a mb_warband_1173.exe, and i might have overwritten the original mount and blade file, if that is the problem how do i fix it.

Eärendil Ardamírë

Subforum Moderator
Deinstall and remove all Warband files (make a backup of the mods which you have downloaded already). Then reinstall them. Normally Native should ask you for the game key when you start up the game.
Top Bottom