In Progress Screen Resolution Bug When returning to map

Users who are viewing this thread

Version number
e1.5.7.261159
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Hi All,

I just purchased the game today and have been having a odd screen resolution bug. I have a 1440p monitor and everything is set to 1440p, All games, desktop etc. I set the game up to run in 1440p however every time i go back to the map from a battle or from visiting a town the game automatically changes the resolution of the game to some unknown resolution. However when i check the setting again it says " desktop resolution " buts its not. this means my character does not move where i click and the party flag is far away from the actual character. the only fix is constantly having to reselect the 16:9 1440p setting manually again. i just cannot work out what it it doing? Can anyone help?

Here is a video i made which shows the problem, video quality should improve soon but hopefully you can make out the issue in the mean time.


****UPDATE TO MODS*** After much messing around today i have discovered this is bug caused by Nvidia DLSS. After turning off this setting the problem goes away. the implementation of DLSS into the game is broken ( for me at least )
 
Last edited:

Abdullatif

Developer
Hi All,

I just purchased the game today and have been having a odd screen resolution bug. I have a 1440p monitor and everything is set to 1440p, All games, desktop etc. I set the game up to run in 1440p however every time i go back to the map from a battle or from visiting a town the game automatically changes the resolution of the game to some unknown resolution. However when i check the setting again it says " desktop resolution " buts its not. this means my character does not move where i click and the party flag is far away from the actual character. the only fix is constantly having to reselect the 16:9 1440p setting manually again. i just cannot work out what it it doing? Can anyone help?

Here is a video i made which shows the problem, video quality should improve soon but hopefully you can make out the issue in the mean time.


****UPDATE TO MODS*** After much messing around today i have discovered this is bug caused by Nvidia DLSS. After turning off this setting the problem goes away. the implementation of DLSS into the game is broken ( for me at least )
Hi, may I have your Documents/Mount & Blade II: Bannerlord/Configs/engine_config.txt please?
 
Hi, may I have your Documents/Mount & Blade II: Bannerlord/Configs/engine_config.txt please?

number_of_ragdolls = 5
max_simultaneous_sound_event_count = 2
invert_mouse = 0
foliage_quality = 4
decal_quality = 4
texture_filtering = 5
graphics_adapter = 0
first_time = 0
brightness_calibrated = 2
texture_budget = 3
texture_quality = 2
show_framerate = 0
max_framerate = 165
cheat_mode = 0
water_quality = 2
display_width = 2560
display_height = 1440
display_mode = 2
selected_monitor = 0
force_vsync = 0
enable_cloth_simulation = 1
enable_flora_sway = 1
shader_quality = 2
postfx_dof = 0
postfx_sssss = 1
postfx_ssr = 1
postfx_bloom = 0
postfx_sunshafts = 1
postfx_streaks = 0
postfx_hexagon_vignette = 0
postfx_vignette = 0
postfx_grain = 0
postfx_lens_flares = 0
postfx_chromatic_aberration = 0
postfx_motion_blur = 0
tesselation = 1
particle_quality = 2
particle_detail = 2
terrain_quality = 2
shadowmap_type = 2
shadowmap_filtering = 1
shadowmap_resolution = 3
disable_sound = 0
sound_device = 0
sound_output = 2
enable_dynamic_resolution_scale = 0
dynamic_resolution_fps_target = 60
lighting_quality = 2
antialiasing_technique = 5
dlss_technique = 0
environment_detail = 4
character_detail = 4
safely_exited = 0
enable_controller_vibration = 1
weapon_trail_amount = 0.5384
display_refresh_rate = 23.0000
master_volume = 1.0000
music_volume = 0.5995
sound_volume = 1.0000
mouse_sensitivity_coefficient = 0.4028
gamma = 2.2000
sharpen_amount = 0.9028
control_mouse_movement_y_scale = 1.5000
control_mouse_movement_max_accumulation = 40.0000
control_mouse_movement_accumulation_decay_speed = 100.0000
brightness = 0.0000
brightness_min = 0.0150
brightness_max = 1.0060
exposure_compensation = 0.2477
resolution_scale = 100.0000
antialiasing_technique = 5
occlusion_technique = 1
 

Abdullatif

Developer
number_of_ragdolls = 5
max_simultaneous_sound_event_count = 2
invert_mouse = 0
foliage_quality = 4
decal_quality = 4
texture_filtering = 5
graphics_adapter = 0
first_time = 0
brightness_calibrated = 2
texture_budget = 3
texture_quality = 2
show_framerate = 0
max_framerate = 165
cheat_mode = 0
water_quality = 2
display_width = 2560
display_height = 1440
display_mode = 2
selected_monitor = 0
force_vsync = 0
enable_cloth_simulation = 1
enable_flora_sway = 1
shader_quality = 2
postfx_dof = 0
postfx_sssss = 1
postfx_ssr = 1
postfx_bloom = 0
postfx_sunshafts = 1
postfx_streaks = 0
postfx_hexagon_vignette = 0
postfx_vignette = 0
postfx_grain = 0
postfx_lens_flares = 0
postfx_chromatic_aberration = 0
postfx_motion_blur = 0
tesselation = 1
particle_quality = 2
particle_detail = 2
terrain_quality = 2
shadowmap_type = 2
shadowmap_filtering = 1
shadowmap_resolution = 3
disable_sound = 0
sound_device = 0
sound_output = 2
enable_dynamic_resolution_scale = 0
dynamic_resolution_fps_target = 60
lighting_quality = 2
antialiasing_technique = 5
dlss_technique = 0
environment_detail = 4
character_detail = 4
safely_exited = 0
enable_controller_vibration = 1
weapon_trail_amount = 0.5384
display_refresh_rate = 23.0000
master_volume = 1.0000
music_volume = 0.5995
sound_volume = 1.0000
mouse_sensitivity_coefficient = 0.4028
gamma = 2.2000
sharpen_amount = 0.9028
control_mouse_movement_y_scale = 1.5000
control_mouse_movement_max_accumulation = 40.0000
control_mouse_movement_accumulation_decay_speed = 100.0000
brightness = 0.0000
brightness_min = 0.0150
brightness_max = 1.0060
exposure_compensation = 0.2477
resolution_scale = 100.0000
antialiasing_technique = 5
occlusion_technique = 1
Thank you.
 

Munakas

Recruit
Just informing that the bug still exists and that I have this exact issue with the DLSS turned on. Tested on e1.5.10 and e1.6.0beta.
 

Munakas

Recruit
The DLSS bug is still in the 1.6.1 beta. Currently you have to visit some UI screen like party or inventory and the game "refocuses" itself again. This happens everytime you exit an instance where you control your character(arena, visit tavern, battle or visit keep etc).
You get the game to refocus without visiting an UI screen by scrolling out in world map and clicking on a town away from your current position so that the game zooms in and focuses on that newly selected town. When this bug happens, the map UI elements and the map 3D graphics are "not aligned" and feels like the graphics are seriously zoomed in and the UI is on a different zoomlevel(farther).
Hope you crack this mystery soon :smile: Loving the game, although I hope we get special companions with their own quests, instead of these generic wanderers.
 
Top Bottom