Need More Info General Sandbox.dll is protected or corrupt error

Currently viewing this thread:

Version number
1.5.7
Branch
Main
Modded/unmodded
Modded

Lonewarrior

Sergeant
Over the last few days I have been getting weird crashes on 1.5.7

This happens when using a custom campaign map and the crashes started on the campaign map, but once they start it affects the unmodded game as well.


Using Dnspy I was able to get a reference to sandbox.dll as the cause and the error was "attempting to read protected memory or it may be corrupt".

The first crashes were random crashes on the main map and the second was everytime I went to the troop menu and clicked on a troop that I had added to my mod's xml.

I decided to test this and created a blank troop xml and that single troop (even though it was a copy of a base game troop) would keep crashing when I clicked on it.
Meaning any troops I added would crash.

After this was the second time sandbox.dll was flagged up on DNspy as "attempt to read or write protected memory or may be corrupt".


I deleted both the dll folders for sandbox for the bannerlord and mod tools, and verified steam which fixed the issue.

I dont know why it keeps getting corrupt, but there may be an issue with 1.5.7 sandbox.dll but I have not edited it in any way at any point.

I was able to reproduce this bug like I said but creating a single troop entry which was a copy of an basic troop and after deleting the sandbox.dll s and verifying steam the issue was fixed for a second time




EDIT: I am getting this error again on a custom campaign map. Verifying on steam has fixed the issue again but this is at least the third time since the last hotfix I’ve had to do this

First picture is first crash, followed by putting a break point in and loading the game again which flags sandbox.dll in the second image

I have deleted all the files in Sandbox/bin and deleted all the win64_shippingclient and editor files and then verified on steam again after testing this error appears consistently over and over.
After doing this the crashes ceased happening on the first play through indicating that some of these files were causing the crashes.

Edit 2: To reproduce this I had to be using a custom map.
After testing it with vanilla map there were no errors but after creating a new campaign map and testing it, after a few hours the same message appeared again so it appears it’s related to custom campaign maps in some way which is triggering the crashes which then start happening even if you start a new game on the vanilla game campaign map:

Verifying the sandbox dlls again temporarily fixed the issue



bandicam_2021-02-20_03-23-58-963.jpg

bandicam_2021-02-20_03-27-36-423.jpg
 
Last edited:

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Can you send us the scene files?
RAR/ZIP the scene files and upload the RAR/ZIP to upload.taleworlds.com. With the URL of this thread and your username to be written to the description. There are 2 folders located under the below paths with your scene name:
  • WOTS\Modules\SandBox\SceneObj
  • WOTS\Modules\SandBox\SceneEditData
 

Lonewarrior

Sergeant
Can you send us the scene files?
RAR/ZIP the scene files and upload the RAR/ZIP to upload.taleworlds.com. With the URL of this thread and your username to be written to the description. There are 2 folders located under the below paths with your scene name:
  • WOTS\Modules\SandBox\SceneObj
  • WOTS\Modules\SandBox\SceneEditData
Can you send us the scene files?
RAR/ZIP the scene files and upload the RAR/ZIP to upload.taleworlds.com. With the URL of this thread and your username to be written to the description. There are 2 folders located under the below paths with your scene name:
  • WOTS\Modules\SandBox\SceneObj
  • WOTS\Modules\SandBox\SceneEditData
I’m not 100% sure but when I get this error in DNspy it highlights the error under navmesh.
It’s possible that the game was trying to spawn something on impassable terrain as recently the modding community has created a fix for the map height error and since then I haven’t seen this sandbox corrupted error.
I don’t know if it’s possible that my map corrupted the sandbox dlls somehow but if it happens again I will sent the files over but for now it might be fixed but I haven’t had time to throughly test it
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
We can comment more detailed if we see the scene. We will enable asserts and warnings in the modding tools soon. This will make sure the tools will give better error messages before crashing.
 

Lonewarrior

Sergeant
We can comment more detailed if we see the scene. We will enable asserts and warnings in the modding tools soon. This will make sure the tools will give better error messages before crashing.
OK ive included that in this file.

Is this everything you need?
 
Top Bottom