Rough Tied Bracers are too good

Users who are viewing this thread

Ruffing

Recruit
As the title suggests I am posting this to draw attention to an admittedly minor issue, but one that irks me all the same. Rough Tied bracers are *way* too good. It's to the point where it's actually hard to find upgrades, playing Imperial I have to get full lamellar plate gauntlets to beat them, and even then the weight to protection ratio is still ridiculous. On top of that they are acceptable to wear in civilian settlements, so wargear that provides superior protection to proper gauntlets and weighs a fraction as much is the best civilian attire for you're hands. Now some may be wondering why this is a problem, well I again will say this is a matter of personal taste but you get these bracers pretty early in the campaign. It varies game to game i'm sure but I generally pick these up early midgame, as in I just loot them from some random mob. This kind of throws the progression out of whack somewhat and apart from that they aren't very appealing and don't go well with alot of higher end armors. I feel like mail mittens or lordly reinforced padded mittens should give better protection than an old piece of scrap metal tied to some rough hide/ fur bracers with no gloves. It's legitimately difficult to find better armor for your hands and generally you have to buy it for a pretty high price.
 
But if we look at the overall armours and their values, you will see some differences which should not be(price, protection and weight values).
 

Ruffing

Recruit
I'm pretty sure, based on his other threads, that he is playing on a version of the game from several months ago. Back then they had ~30 armor.
I wondered if I might somehow be behind patch wise but I would think it updates automatically. I'll try updating my game. If this ends up being the issue then thanks for letting me know.
 

Ruffing

Recruit
I'm pretty sure, based on his other threads, that he is playing on a version of the game from several months ago. Back then they had ~30 armor.
it seems that for some reason my game is on version e1.4.3 rather than the latest patch. This despite the fact I have it set to auto update. I looked into the matter and it seems you have to manually change the version you are playing on. Thanks to you guys for helping me figure out I was behind patch wise, guess I've got alot of changes to catch up on.
 
Top Bottom