• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Need More Info ''rescue from bounty hunters / forest bandit problem'' [BUG] --Companion released because of peace.

Users who are viewing this thread

Hi, ive tried checking into the ''known issues'' and didnt see both of them here so here i am.

to start of i currently play on game version : e.

pc specs
OS : Windows 10 64Bit
CPU : Ryzen 7 2700X
GPU : Radeon Rx 580 8GB Nitro+
RAM : 2x 8gb Hyper X Fury 3200Mhz
Motherboard : ASrock B450M hdv r4.0
storage : Samsung 1TB HDD

EDIT : i forgot to mention i use the mod ''BuyPatrols''

both quests were located in ''Rotae''

when i clicked on ''rescue associate from bounty hunters'' and i want to have my companion do the quest for me it bring up the prisoners menu when trying to add troops. i can add the prisoners but it doesnt count as a troop.

''forest bandit problem'' same problem as above. when i try to assign a companion to do the quest it brings up the prisoner screen again. same problem. they dont count as troops.

''companion released because of peace''
i had this problem yesterday and restarting my pc seemed to have fixed it for a little while. but now the vladian declared war against me and it says ''Dherek the fatherless has been released because of peace treaty'' even though he was with me in my army and no faction made peace at all. this keeps popping up when my kingdom declares war / or a peace treaty.

( btw i have no control on both. ) i try to click on ''declare war / make peace'' but both are greyed out for me.

independent kingdom. but havent finished the ''capture 2/3'' of the imperials'' <---- maybe i cant make peace / declare war because i havent ''completed'' it yet ) but no idea to be honest.
Last edited:
I forgot to add this in the title'' infinite battle'' i thought i saw it was fixed somewhere but its happening for me again. a enemy lord has 0 troops. 2 of my vassals attacked him but it didnt seem to go away. so i thought might aswell help them out but its give no option to attack / leave / surrender. i saved before i entered the battle ( glad im did because it was stuck like this ) i made a screenshot of it because its difficult to explain.



Community Support
Community Support
Hello, thanks for reporting this issue. Unfortunately, we were not able to respond to this topic when this topic first created.
We believe that this issue might have been fixed since the creation of this topic. If you are still experiencing this issue on the latest live or beta versions of the game at the moment please leave a reply to this topic so that we can forward this issue to the team for investigation.
Top Bottom