Resolved Random crashes and huge lag from nowhere (Singleplayer)

Currently viewing this thread:

Napmop

Recruit
Hi,

For several days I've played this game without any problems. But yesterday, after playing for a bit and restarting the game it refused to boot. I've since then not been able to play, but I've somehow managed to get the game started. But it is in an unplayable state.
As far as I remember, all I did between the two sessions were to install Zoom. I've since uninstalled it, but it did not solve anything.

I was playing it good with the compatibility Proton 6.3-4, until it refused to boot. Now it only boots if I don't start it with a compatibility, but then as said it is unplayable due to lag and crashes.

The game is really sluggish both on the world map and in battles. The inventory screen takes several seconds to load. I crash if I enter any sort of trading screen.
The oceans seem to be filled with pictures of cows??

I'm on Ubuntu 20.04, somewhat new to the OS. Other titles do not behave like this. Note that hardware is not an issue - I run more demanding titles without a problem.

I've tried..

-Reinstalling the game, several times.
-Unsubscribing from all mods (tried without DLCs too, as I'm playing Native).
-Rebooting
-Updating Nvidia drivers. Changing them too.
-Started a new game.
-Loaded another savefile.
-Tried different compatibilities.
-Verifying game files.
-Deleting the rgl_log.txt file.
-Downloading the non-Steam version here from the website.
-Reinstalling Wine.
-Setting all settings for graphics to the lowest possible.

Now I'm running out of ideas and relevant threads.
Tips, ideas? I can't find another thread with this exact behavior reported.
 

SnakeBae

Recruit
The game has a lot of issues on its own and trying to play on Linux is bound to create some problems.

The only thing I can think of is that the Zoom install you've done might have messed something up with kernel, but a GPU driver reinstall should have fixed that.

I suggest finding some random HDD lying around, or use a Virtual Machine to see how the game behaves on a fresh install.

Also are any other games affected? That would narrow it down a bit.

I don't use linux right now, so I also suggest checking out different Proton versions and look for if anything changes.

I'm sad to admit I'm not a professional or really knowledgable about this stuff, so I might not be able to help you too much.
 

Napmop

Recruit
I tried to fix it, but those fixes made more games unplayable. The more i tried the deeper I dug my own grave.
So I reinstalled Ubuntu and now the game works fine.

Thank you for you reply though!
 
Top Bottom