In Progress Problem with graphic (Don't know how to fix this)

Users who are viewing this thread

Version number
e1.6.1
Branch
Main
Modded/unmodded
No, I didn't use any mods.

Ntsi

Recruit
Hello everyone,

I have a graphics problem and I don't know how to fix it. The problem is with the graphics on the world map. The graphics are grim, as if the graphics engine has gone back 15 years. I wrote about this problem once and no one helped me, but I had no proof of it. Now I have found and unfortunately I have not found a solution. Browsing through old saves I found a game the graphics are fine but when you enter and exit menus, inventory or stats it causes a graphics issue. After reloading, there is no problem, but when I enter the menu, for example, the problem appears again and so every time. I don't know if anyone understands so I'll add two photos here. As you can see, the problem is quite serious, because the graphics become pale and colorless, which discourages me from playing ... That's why I haven't played for about a year ... Please help! I have all the sliders at their maximum and the game ran smoothly in over 80 frames. I also don't have any mods. The problem has been around before, around version 1.5.

Without problem

MLmyNwU.jpg


Problem

0pddL1K.jpg


OS: Windows 10
GPU: Gtx 1660 S
GPU Driver Version: latest
CPU:Ryzen 5 3600
RAM:16gb
Motherboard: MSI b450-a pro max
Storage Device (HDD/SSD):SSD
 
Last edited:

Ntsi

Recruit
Hi thanks for the answer. I just uploaded a file called: "New version and still problem". Without the quotation marks, of course. Thanks for your help, hope someone can find a solution.

I don't know what it looks like next, but I have downloaded version 1.5.1 and the problem is no longer there. I even downloaded the beta version 1.6.3 and there is a problem too ... I don't remember exactly which version the problem started with, but I think it's 1.5.3 - 1.5.5. When I have a moment, I will download each version and check it, but for now I can play on version 1.5.1? : /
 
Last edited:

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i will forward your save file and the issue to the QA team. Meanwhile, can you try deleting the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders and verifying your game files?
 

Ntsi

Recruit
Hello, i will forward your save file and the issue to the QA team. Meanwhile, can you try deleting the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders and verifying your game files?
Hi,
I followed the recommendations by deleting folders, but it didn't help. I've already tried reinstalling the game a few times, removing all of its leftovers, but that didn't help. The graphics bug only occurs above version 1.5.1.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, our team was not able to reproduce the issue. Can you please capture a video of the issue happening? it could help us understand the issue.
 
I have the same issue.. I just bought the game. been playing MB1 for years. I actually thought it was supposed to look like that.. but seeing his first picture. I guess not..

I just installed the newest nvidia drivers also..
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
I have the same issue.. I just bought the game. been playing MB1 for years. I actually thought it was supposed to look like that.. but seeing his first picture. I guess not..

I just installed the newest nvidia drivers also..
Hello, do you also experience the issue mid-game? if so can you please record of a video of it happening so i can forward it to the QA team?
 

Ntsi

Recruit
Hello, our team was not able to reproduce the issue. Can you please capture a video of the issue happening? it could help us understand the issue.

Hello, of course, and forgive that it took so long, but only today did I find some time. I put the film on youtube. As you can see, despite the latest version and maximum settings, the problem still exists and unfortunately I have no idea how to solve it. I really hope you find a reason. Thank you and best regards.

 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i have been informed that the devs was not able to reproduce the issue. They also added that if the issue is persistent on a new campaign on e1.6.5, this could be linked with an atmospheric change that has been added to the game in the earlier versions. At this point they could not find any problems that could be the reason for this issue. Sorry for the inconvenience. Should the issue be persistant in the future updates, please try a clean install.
Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 

Ntsi

Recruit
Hello, i have been informed that the devs was not able to reproduce the issue. They also added that if the issue is persistent on a new campaign on e1.6.5, this could be linked with an atmospheric change that has been added to the game in the earlier versions. At this point they could not find any problems that could be the reason for this issue. Sorry for the inconvenience. Should the issue be persistant in the future updates, please try a clean install.
The latest version of the game, and unfortunately it still happens. I have already lost hope of solving this problem.
 
Top Bottom