• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Resolved Possible fix for crash problem came with hotfix

Users who are viewing this thread

Kenzo-0-

Sergeant
After 1.4.3 hotfix i've recieved all sorts of crashes. I've seen devs telling people to uninstall the FixedLauncher mod, which wasn't active on my list. I've re-installed but problem wasn't fixed until i manually deleted the files which was changed or added by FixedLauncher mod. Perhaps when i unintstalled the game from steam, thoose 3rd party files were not removed and after the fresh installation the game files were corrupted again. Here's what worked for me. Go to the game folder and remove thoose files (for your safety don't delete them, just remove em somewhere else)
bin>win64_shipping_client>
0harmony.dll
launcherpatcher.dll
launcherpatcher.pdb
taleworlds.mountandblade.launcher.exe.config
And remove the fixed launcher from your module folder.
After removing thoose files, all that's left is to verify the integrity of the game files from steam, after couple minutes your game should work. At least worked for me, let me know the results.
 
Last edited:

Kenzo-0-

Sergeant
Seems like it has worked for not only me but also for couple of ppl as well
 
Last edited:

Dogmeat

Recruit
Edit: my latest crash was a self inflicted cut an past idiot mistake messin up an original table - facepalm (dumb mistakes are easy 2 fix at least)

So to make this post useful i can confirm your way is the best way to fix the shader crash error - basically its an old mod file that replaced an original file or anyway cant be seen in validate so isnt updated. Deleting the offending files you mention forces the validate to upload new unbugged files.
 
Last edited:

Finn of Eire

Recruit
After 1.4.3 hotfix i've recieved all sorts of crashes. I've seen devs telling people to uninstall the FixedLauncher mod, which wasn't active on my list. I've re-installed but problem wasn't fixed until i manually deleted the files which was changed or added by FixedLauncher mod. Perhaps when i unintstalled the game from steam, thoose 3rd party files were not removed and after the fresh installation the game files were corrupted again. Here's what worked for me. Go to the game folder and remove thoose files (for your safety don't delete them, just remove em somewhere else)
bin>win64_shipping_client>
0harmony.dll
launcherpatcher.dll
launcherpatcher.pdb
taleworlds.mountandblade.launcher.exe.config
And remove the fixed launcher from your module folder.
After removing thoose files, all that's left is to verify the integrity of the game files from steam, after couple minutes your game should work. At least worked for me, let me know the results.
thank you
 
Top Bottom