Need More Info Poor performance, stuttering

Users who are viewing this thread

Plurificico

Recruit
I play with a mix of low and medium setting and only 200 troops on a battlefield, at the beginning of a battle i reach 144 frames but when the troops start fighting the game begins to stutter , and the sieges are barely playable. I find it very weird because in custom battle i can play with 500 troops without stuttering

My specs:
OS: windows 7
CPU:AMD FX(tm)-8320 Eight Core Processor
GPU: GeForce GTX 1060 3GB
Monitor: AOC with 144 Hertz
RAM: 16,0 GB
 

Dratgon

Recruit
WBNW
I'm almost using the same setup as you. Did you run out of RAM while it began to stutter? Check task manager performance tab next time it starts to stutter and report back what you find.

I'm only running at 60 fps maybe that could be the issue? Try to lower this?
 

Plurificico

Recruit
In sieges my cpu usage is about 74% and memory usage about 13 GB
In battles my cpu usage and memory usage is about the same but battles have less stuttering
I changed the monitor refresh rate to 60 and cap to frames to 60 but that didn't make it any better
 
Last edited:

bFaceIII

Community Support
M&BWBWF&SNWVC
Hello, thanks for reporting this problem. Unfortunately, we were unable to respond to this thread when it was first created. We believe the issue may have been resolved since the creation of this topic. If you are currently experiencing this issue with the latest live or beta versions of the game, please update this thread so we can forward this issue to the team for investigation.
 
Top Bottom