Ping and Packet-Loss Fix for German Players When?

Users who are viewing this thread

Ah ****, here we got again...
I may have made a post on this topic already, but evidently neither my posts, nor the posts of the other people that are affected by this have changed anything. It's been almost exactly a year now, since Germany players have begun to experience massive problems with their connection to the TW servers. Those problems range from constant packet-loss to the player just being kicked mid-skirm, TDM or whatever.

Now my question is, how the f*ck is a company as big as TaleWorlds, with all the money in the world, NOT able to properly host servers?! I mean... every MP mod in the history of Bannerlord had better servers than TW has rn.

I for my part am experiencing massive delays on both hits AND blocks... i.e. I swing at someone, they start their swing after I started mine, yet they still land their hit before my hit connects, even tho they have an equal or even slower weapon. And don't tell me about "turning into the swing" now, cuz I am doing that as well...

Usually, I am ok with a bit of lag every now and then, but the servers right now are absolutely exhausting and have cost me two keyboards already. At this point, the only mode thats actually playable for me, is duel... And even there, where I only have to block one person, I still experience a delay whenever I block or swing. I used to have like 19-25 ping on most Warband MP Servers, rn I am close to 60 whenever I play, and that ping is being accompanied by Lord Packetloss... Which makes it even worse.

So please, for the love of all the butter in Calradia, fix your servers...


P.S.: And no you c*cks... It's not MY internet.. I have like 4 ping on Chivalry II and around 20 on Battlefront II. I tested it!
 

Namakan

Grandmaster Knight
M&BWBWF&SNWVC
yup, also from germany and ping is consistently higher (for around a year, too) than everywhere else and the packetloss icon is on literally all the time.

if you're not gonna fix your server situation (this thread, SA servers, ...), let us host our own.
 

Errayn

Knight at Arms
I have that problem too, when packetloss happens too much switch to vpn, thats only solution untill custom servers, because Tw will stick to their ****y provider.
 
yup, also from germany and ping is consistently higher (for around a year, too) than everywhere else and the packetloss icon is on literally all the time.

if you're not gonna fix your server situation (this thread, SA servers, ...), let us host our own.
+1
 

Ngaldos

Recruit
LOL WE DON'T EVEN HAVE SERVERS IN LATIN AMERICA.
Check your privileges son.
(Cuz we paid the same amount of money and I have half the game you have).
 
Top Bottom