• If you are reporting a bug, please head over to our Technical Support section for Bannerlord.
  • Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Users who are viewing this thread

JimmyCrid

Recruit
Bought the game on launch and struggled with a few minor FPS drops/Stutter issues, usually when initially entering combat the game would lock up and stutter quite badly and then iron itself out, running smooth until the end of the fight (The drops usually start when charging an enemy/first point of contact.) This happened regardless of graphic settings/framerate limiting/audio changes etc. (I've been sifting through forums for a while now)
I thought these issues would have been fixed with the latest patch (e1.0.4) where fixes for memory leak etc were stated, but since downloading said patch these issues have gotten worse, now experience major stuttering and FPS drops throughout the entirety of combat and then returns to it's usual 50 - 60 fps as soon as the fight is won.
Additional stuttering and drops occur when loading into towns and cities, Also stuttering on the Map is also more common.

System spec:
-AMD FX 8350 Eight Core
-Nvidia GTX 960 4GB
-8GB RAM

I am planning on upgrading the RAM to 16GB in the following week.
 

Kangamangus

Sergeant
M&BWBWF&SNWVC
Does it happen every fight, or only after you've been playing a while? Some people have said they get memory leaks after saving/loading multiple times in a session. Restarting the game seems to help them. That might only be for load times, though.
 

JimmyCrid

Recruit
UPDATE:

Seen a lot of people posting this having the same issue as me.
Also wanted to add, custom fights are smooth like butter. 250v250 runs absolutely fine, no lag whatsoever.

Starting to think this is an issue with the Campaign more than anything.
 

redcomet89

Recruit
UPDATE:

Seen a lot of people posting this having the same issue as me.
Also wanted to add, custom fights are smooth like butter. 250v250 runs absolutely fine, no lag whatsoever.

Starting to think this is an issue with the Campaign more than anything.
damn bro is that rig of yours 10 years old?
 

Celebrimborr

Regular
First of all, we have to wait for optimisations. I don't know if it will help you, but you can try to: debloat your windows, defrag your drives, disable windows services that are useless like sysmain etc. Right now i am using process lasso that helps me to run bannerlord smoother with less stutters in my case.
Here's a link that helps you to optimise your pc. It really helped me, a lot (again, in my case, but you can try to see some results)
I can run bannerlord with some settings on high and i have a ****ty pc: GTX 750 ti
i3 4160 3.60ghz
8 GB Ram (4x2)
In-Game Settings:

Shader Quality, LightingHigh
Texture Streaming BudgetVery High
Textures, Shadows, Environment, Terrain, Decals, WaterLow
Shadow TypeStatic Only
Particle Detail, Particle Quality, Foliage Quality, Character DetailMedium
AntialiasingSMAA
Texture FilteringAnisotropic 8x
OcclusionTSAO
Shadow FilteringPCF
Sound Channels128
English is not my native language, sorry for bad grammar.
Have a good day!
 
UPDATE:

Seen a lot of people posting this having the same issue as me.
Also wanted to add, custom fights are smooth like butter. 250v250 runs absolutely fine, no lag whatsoever.

Starting to think this is an issue with the Campaign more than anything.
same problem here, for me the custom fights and multiplayer are running smooth aswell.
so you might be right that this is a campaign thing
 
Top Bottom