In Progress Performance decrease since beta 1.5.6

Currently viewing this thread:

Version number
1.5.6
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

Holger55

Recruit
i came back to the game after 5 months with 1.5.6 and was shocked how worse the performance has become. when i played first after early access i could get stable 60 fps on medium settings but now i am struggling to get 50+ fps on lowest settings even in a tournament, its not better in 1.5.7.
the terrible stuttering on the world map and general lag i could fortunately fix by moving the game to my m.2 ssd

Computer Specs:
OS: WIN 10 64
GPU: GTX 1060 6 GB
CPU: Ryzen 5 1600
RAM: 16 GB DDR 4 2667 MHz
Motherboard: Asus B350 plus
Storage Device (HDD/SSD): Game: m.2 SSD, OS: SATA SSD
In-game graphic settings: low

i am not using any mods and also had never
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 
tried the recent update to 1.5.7 w/ latest hotfix. The result is the same - same UI lags, same (or even more) lags on campaign map. Not even close to how smooth it was on 1.5.5. Only first game launch loads slightly faster comparing to 1.5.6.

win10 64 latest branch
i5-9400F
16Gb
GTX1050
GAME: Raid 0 2 hhd's, OS: SATA SSD
 
The game was great untill 1.5.6. After this it works like crap. Playing it now is corrupting all my impressions... And there are more and more news about full release. With what? 1.5.7 didn't fix anything.
 

Shun

Squire
WB
beta 1.5.8., the UI lag is still there. Did not get enough playtime to thoroughly check map performance, will update when I get the time.
 

MakinTorf

Veteran
Computer Specs:
OS: WIN 10 64
GPU: Asus Arez radeon vega 56 8gb oc
CPU: Ryzen 7 2700
RAM: 16 GB DDR 4 2133 MHz
Motherboard: Gigabyte aorus x470 ultra gaming
Storage Device SSD: Game: m.2 SSD
In-game graphic settings: high, 1920x1080 240hz

i was watching my memory und saw that it was running full from normal 9GB with the game, going up to 15GB.
i encountered a lot of mountain bandits, really many small groups, sometimes around 10-15 in one spot. btw i have only mountain bandits.
before it crashed again i just exit the game.
 

erroroflog

Recruit
Good day, I am encountering the same issues, every time I switch from one panel to another one or any use of the different menus in-game I have lots of delays. When I was playing in november I dind't have those issues (I dind't play in the last 2 months)
My specs:
OS: Windows 10 64
GPU: NVIDIA GeForce GTX 1070
CPU: Intel (RC) Core (TM) i7-8700 CPU @3.20Ghz
RAM: 32 GB
Storage Device (HDD/SSD): SSD
In-game graphic settings: Low
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 

erroroflog

Recruit
I've uploaded on the link you wrote. One issues Ive had while uploading is when you try to write any description in the box. It delete itself after you click on it again. So I should have sent a test file at around this time with or maybe without any descriptive. Since the details get deleted.
File size : 206.830682
 

erroroflog

Recruit
Concerning my last. After looking at other posts, I fixed my issues by reinstalling M&B completely.
Now I don't have big spikes.
 

Shun

Squire
WB
Do you still experience this problem on the current build?


I am on beta 1.5.8.
UI lag is still the same. The loading times are better, but not as fast as before. Map performance is better, still a bit of stutter there. Battle performance seems lower to me than before beta 1.5.6, but has improved a bit in the last patches.

On the whole, I would say that there have been improvements, but but the game performs still significantly worse than before 1.5.6. So to me, the issues are not fixed.
 

Shun

Squire
WB
With today's hotfix, Inventory, Party and character screens take ~ 5 -7 seconds to open and close. After battle scrren takes similarily long to open/close. That's more or less the same as before.
 

TimIZ

Regular
M&BWB
Do you still experience this problem on the current build?
I updated from 1.5.5 to 1.5.9 and still have the problem with laggy menues and much worse looking graphics although I have the same settings as in 1.5.5.

Update: I deleted all files and made a clean reinstallation of 1.5.9. Graphics are back to normal but the menues are still super laggy and unresponsive.
 
Last edited:

bFaceIII

Community Support
M&BWBWF&SNWVC
I have forwarded these updates to our developers. Thanks for your support and sorry for the inconvenience!
 

Gaijiin

Recruit
lol its been since January 11th at the very least that they have known about his issue and still havnt found a fix. No worries, I'll wait another 2 months to play again..
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 

Murat Türe

Developer
Sorry for your convenience. I have done some tests with 1.5.8 and played the game like 40 minutes. I did not encounter any UI lag or memory increase. I will ask some questions so that we can replicate the issue in our development environment and fix it.
* Which menus are laggy? If you re-enter them after closing, do you still experience the lag?
* Is the lag happening even after a long gameplay session? Did you try the game twice after moving into the 1.5.8?
* Do you have any mods? If not and If you are loading a save, did you have mods enabled when that particular save was created?
* For the memory issue, can you check the memory usage of Bannerlord while playing the game?

Thanks in advance. Hopefully we will fix this issue in short time.
 

TimIZ

Regular
M&BWB
*1: Post battle, loot, party, trade, recruiting; lag is still there when reentering the trade menue
*2: have only tried for max 30 minutes but the problem is there all the time; playing 1.5.9 btw
*3: no mods; no
*4: memory seems to go not beyond 8GB

My settings:
Computer Specs:
OS: WIN 10 64
GPU: RX 580
CPU: Ryzen 5 2600
RAM: 16 GB DDR 4
Motherboard: B450 Gaming Plus
Storage Device (HDD/SSD): Game on HDD, OS on SDD
In-game graphic settings: default medium

Video proof with MSI Afterburner enabled (played for 5 minutes, exited to main menue, reloaded and then started recording):


I think the performance of my graphics card might be the most interesting thing here..

Thanks for your hard work!
 
Last edited:
Top Bottom