Patch Notes e1.6.3

Users who are viewing this thread

Worlok

Squire
Check the 1.6.4 and 1.6.5 threads for more details.
This thread is obsolete since 1.6.4 became main branch.
I posted it here because I use 1.6.3 and the patch was pushed for this version. Which in theory should not get anymore since as you said, it's obsolete (well not the patch but the thread, but still..).
 
I posted it here because I use 1.6.3 and the patch was pushed for this version. Which in theory should not get anymore since as you said, it's obsolete (well not the patch but the thread, but still..).
Oh you mean you got an update despite playing on 1.6.3?
Sorry, my bad!
 
Top Bottom