Patch 1.2 - My experience so far

Users who are viewing this thread

Up front, I like the changes, I've noticed a few Warband features in the game. I'm enjoying so far , keep up the warband porting.

Voices are great ! need more.

Quest - Escort caravan needs work. You get attacked by 40 barbarians no matter where you are, in Aserai land (40 skin covered bar-bars), all other lands (40 skin covered bar-bars). Please, use appropriate bandits for each region, and vary the number (from 20 - 60)

BUGS - crashes - NONE ! seems very stable now I updated GPU drivers and play in windowed mode.


AW.
 
Last edited:
-- Update --

Voices are REALLY good, you even have different classes - Noble, Merchant, Commoner etc slang., with different cultures as well.

Quests are good but can be repetitive. "caravan Ambush" Needs work, Ambusers always seem the same. Plus Strat raider figure is a Slider, no leg movement by the horse. Looks REALLY lame ! not up to TW standards.

Troops seem to get promotions far too easily, I get an expensive, elite army very quickly. I play on "Realistic" difficulty.

The new Hideouts are sweet although there seems to be crash bug there somewhere. Already logged.

---- Additional ---

Wedding Video clip was excellent, even though it wasn't a video as my character, my wife's character and flags were correct. Brilliant ! :grin:

--- Additional ---

Also the Kingdom activation video is Excellent. All my characters around the war table. Brilliant ! :grin:

AW.
 
Last edited:
Stopped testing - Could play on Low performance for a while but crashes kept creeping in. Tried uninstalling, deleting everything and doing a clean reinstall but now I cannot even create a new character. Constant crashes "Locked Texture failed" error message.

What is the minimum GPU tested for this patch ? I have an old GFORCE 1080.

AW
 
I was playing for a while with a GTX 960 with no problems but have since upgraded to a Radeon 6600. Crashes have never been a problem for me, none at all in 1.2. I'm sorry for your bad luck.
 
Ah the nightmare that is PC gaming.

I’ve never had crash issues until this update, but for others the crashes have ceased. Prime example of how and why coding and development can be a nightmare. I hope it gets fixed for me.

I also had an issue where my companions could no longer be assigned to party positions once I was defeated in battle. That desperately needs to be addressed. Makes the game borderline unplayable, and I’m not one to save scum to death to avoid ever losing a battle
 
Ah the nightmare that is PC gaming.

I’ve never had crash issues until this update, but for others the crashes have ceased. Prime example of how and why coding and development can be a nightmare. I hope it gets fixed for me.

I also had an issue where my companions could no longer be assigned to party positions once I was defeated in battle. That desperately needs to be addressed. Makes the game borderline unplayable, and I’m not one to save scum to death to avoid ever losing a battle

If the companion thing is what I was experiencing, go to any settlement, leave your companions there, leave and immediately go back to settlement, it'll show you "finding" them, then you can take them into your party and place them.

As for me, the errors are incredibly frustrating. I keep getting a MobilePartySpeed bug or something, doesn't appear to have anything to do with any of my mods (and I'm using far less mods than usual lol). I think some random party gets spawned that bugs out, and I have no idea how to replicate it. But kinda makes me think it's a corrupted party a la the old Baltakhand level 2 walls bug. At least I get an error message with this one, which I didn't with the Baltakhand one, but end result is the same, and worse in this instance because I don't know what causes it or how to avoid it. It was simple to just not go near Baltakhand before lol
 
Last edited:
If the companion thing is what I was experiencing, go to any settlement, leave your companions there, leave and immediately go back to settlement, it'll show you "finding" them, then you can take them into your party and place them.

As for me, the errors are incredibly frustrating. I keep getting a MobilePartySpeed bug or something, doesn't appear to have anything to do with any of my mods (and I'm using far less mods than usual lol). I think some random party gets spawned that bugs out, and I have no idea how to replicate it. But kinda makes me think it's a corrupted party a la the old Baltakhand level 2 walls bug. At least I get an error message with this one, which I didn't with the Baltakhand one, but end result is the same, and worse in this instance because I don't know what causes it or how to avoid it. It was simple to just not go near Baltakhand before lol
Ah. I tried leaving them in a settlement and then bringing them back to party, but not leaving the gates after doing it and then popping back in before the invite.

Thanks for the tip!
 
Ah the nightmare that is PC gaming.

I’ve never had crash issues until this update, but for others the crashes have ceased. Prime example of how and why coding and development can be a nightmare. I hope it gets fixed for me.

I also had an issue where my companions could no longer be assigned to party positions once I was defeated in battle. That desperately needs to be addressed. Makes the game borderline unplayable, and I’m not one to save scum to death to avoid ever losing a battle

I've fixed my many crashes, just needed to run the game in Window box. I edited the Config.txt file to increase the resolution to 3700 X 2000, and I get an almost 4K in stable window box.

Strange, all these unstable crashes I got before just by setting to Full screen mode Or 3860 X 2160 windowed mode ??? Maybe it's my old 8G GPU ??? All this weird crashes reminded me of "Rogue pointer bugs" ,where you have memory pointers pointing off into the void, not being setup correctly OR a function returning a NULL pointer , is used in the code.(yes, I'm on old "C" programmer). I bet that's the problem, running functions to setup screen resolution / allocate memory but not testing the return code / memory address.

Yes, the previous way to assign companions / soldiers to certain groups was far superior to the "console friendly" garbage we have now. I'm always finding a foot companion being assigned to a horse group, and they have to chase down the horses, ie they are left behind to be surrounded and killed by enemy horsemen.

AW
 
Game is now stable.

But game is FAR TOO WEAK !, I play on Bannerlord (realistic) but this has been NERFED far too much, Yes, I realize this was done to help Console players but it went far too far, realistic needs to return to realistic.

AW
 
My Son's coming of Age video was excellent ! Camera orbits around father & Son, and as it is blocked by a tree or other obstacle , the boy ages 7 or so years - brilliant ! Then the final screen of the father embracing his son, and whispering in his ear "Son, you are a man now, you can wear the red dress! .."

They then head off to the gender transition hospital .

Brilliant.
 
WOW! just WOW! new GPU means ultimate details, at fast speed .. with no crashes ! Many of the crashes I had before have vanished. Obviously jumping from 8G mem to 24G made all the difference. Sad when you think about it, all those people with older cards and only 8G.

Will keep testing.
 
Been playing without many issues so far, love all the new features added to 1.2, hoping for more in the next release. (still not up to WB /VC standard .. but)

Still testing .
 
Back
Top Bottom