In Progress Resource Browser Overriding textures does not render correctly when launching the game normally.

Users who are viewing this thread

Version number
e1.5.3
Branch
Main

Shik

Baron
M&BWBWF&S
Summary: Overriding textures does not work properly when launching the game normally.
How to Reproduce
: Create a new module and add a new texture to replace an old in game texture. In this specific instance, the texture is body_male_a_d. Launch the game in the editor and the texture is working fine. However when you launch the game normally the texture will be bugged.
Specific Tool: Resource Browser
Media:
Messed around and added some random blue/woad body paint splotches to the male body texture for testing purposes. Imported the new asset into a new module's asset folder. It renders fine in the editor and properly replaces the texture in the editor build.

As an aside note, there seems to be no way to import this texture without the importer creating an alpha channel. The native body texture has no alpha channel but the imported one does. This seems like another bug.


We launch the game in the editor build. The texture works! Our Battanian warrior now has proper woad body tattoos, although his artistic skills need some work.


However, when launching the game with the normal build, the texture does not render properly.
Launching the game with the editor tools will properly override the textures but launching the game normally will not.
 
Last edited:

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Shik

Baron
M&BWBWF&S
Saw somewhere that publishing the mod might be related to this. After publishing the issue continues to persist. (1.5.3 now)
 

Shik

Baron
M&BWBWF&S
Update on this issue: mixing native normal maps and specular with overridden diffuse textures on one material seems to cause this. When the game is launched in the editor mode you can mix and match overridden and native texture maps fine but it is bugged when launching the game normally. When launching the game normally you have to override every texture map used by the material in order for it to work.
 
Last edited:
Top Bottom