OSP Kit Campaign Outposts! v0.8 - updated 15.07.11

Currently viewing this thread:

produno

Master Knight
M&BWBWF&SNW
Best answers
0
Yes, create it in the forge then request for it to be moved here.

You can post your code in the thread for others to check and improve if need :smile:.
 

HammY2776

Recruit
Best answers
0
well, i get error scn_fort is not defined, the real problem is in my module_scenes i kind of find this line:
  ("fort",sf_generate,"none", "none", (0,0),(100,100),-100, "0x000000003224dfb20004a92f00001d760000611000005679",
    [],[],"outer_terrain_plain"),
umm, isnt that were scn_fort is defined?
and why am i getting this errorr?
 

HammY2776

Recruit
Best answers
0
fixed it, dont know how but fixed it

HammYtheMagnificent said:
well, i get error scn_fort is not defined, the real problem is in my module_scenes i kind of find this line:
  ("fort",sf_generate,"none", "none", (0,0),(100,100),-100, "0x000000003224dfb20004a92f00001d760000611000005679",
    [],[],"outer_terrain_plain"),
umm, isnt that were scn_fort is defined?
and why am i getting this errorr?
 

Caba`drin

Count
M&BWBWF&SNWVC
Best answers
0
HammYtheMagnificent said:
fixed it, dont know how but fixed it

HammYtheMagnificent said:
well, i get error scn_fort is not defined, the real problem is in my module_scenes i kind of find this line:
  ("fort",sf_generate,"none", "none", (0,0),(100,100),-100, "0x000000003224dfb20004a92f00001d760000611000005679",
    [],[],"outer_terrain_plain"),
umm, isnt that were scn_fort is defined?
and why am i getting this errorr?
Sometimes it takes running compile twice to enumerate the id_X (in this case id_scenes)  file with the change for the compiler.
 

Lumos

Archduke
WBWF&SNWM&BVC
Best answers
0
According to the first post, the scenes were made by Nordous (and the fort scene is bob's, IIRC). I can see that you're a Builder of the Gods, but there is no scene by you included in this kit, so I don't understand what you meant, and what reaction you were expecting.

Besides, the last update is dated more than four years ago. That should be information enough.
 

builder of the gods

Sergeant at Arms
Best answers
0
sorry probably told wrong :sad:
I ment when i go ingame there is no scene just empty.
And why have you stopt modding lumos you where great at it :grin:
You explained that way even the most stupid one could implent
 

Lumos

Archduke
WBWF&SNWM&BVC
Best answers
0
builder of the gods said:
sorry probably told wrong :sad:
I ment when i go ingame there is no scene just empty.
Did you copy over the sceneObj files and the proper module_scenes entries? If you did, then I don't know what's going on.

produno said:
Yeah c'mon Lumos. Update this thing :wink:
Would that I could, but that's out of the question for the moment.
 

imado552

Sergeant at Arms
Best answers
0
will someone update this amazing feature or at least tell me is there at least one better or newer then this thanks!!
 

Solipsysta

Recruit
Best answers
0
Hello!
  "outposts!" is now part of "Sands of Faith" mod. It's a great feature (extending the strategical side of gameplay) but unfortunately outpost can be built only three times in the span of a single playthrough. That is due to mod's age and incompatibilities resulting from it.
thewanderingknight said:
- Having several outposts and trying to destroy one can crash the game and corrupt the save (ideally avoid use the destroy
  function since is uncertain how extensive can this bug be).
Is it possible to bypass the problem by either deleting an outpost using MnB_SaveGameEditor or increasing the limit of outposts that can exist simultaneously from 3 to any higher number using one of these tools:
https://forums.taleworlds.com/index.php/topic,108292.0.html ? Maybe it can be solved some other way?
I have no previous experience with codding/programming but this forum brings together many smart and talented modders and I'm hoping that some of them know the answer...
 

kalarhan

Python Saint
Count
WBNWVCWF&S
Best answers
36
Solipsysta said:
Hello!
  "outposts!" is now part of "Sands of Faith" mod
if you are a coder (even if still new and learning), then you can also post in the Q&A thread in the Forge. Include all the info (dont assume people know what you are talking about). Seems like a simple coding issue by your description.

Static parties (like the forts) shouldnt be removed (as in destroyed), they should be enabled/disabled. Dynamic parties can be destroyed.
 

Tocan

Sergeant Knight at Arms
Best answers
14
Made a simple fix for the demolishing bug.
I'm on phone, sorry if the formating is screwed..

Code:
("outpost_demolish", [],
                "Demolish your outpost. (500 denars)",
            [(store_troop_gold, ":gold_amount", "trp_player"),
             (try_begin),
                (ge, ":gold_amount", 500),
                (party_slot_ge, "$g_encountered_party", slot_outpost_level, 1),
                (party_relocate_near_party, "p_main_party", "$g_encountered_party", 1),                 
                (disable_party, "$g_encountered_party"),
                (display_message, "@Outpost demolished."),
                (party_set_slot, "$g_encountered_party", slot_outpost_level, 0),
                (party_get_slot, ":patrol", "$g_encountered_party", slot_outpost_patrol),
                # (party_set_slot, "$g_encountered_party", slot_outpost_patrol, 0), #tocan added later
                (rest_for_hours, 2, 5, 1), # Lumos: This is the last one.
                (try_begin),             
                    (party_slot_eq, ":patrol", slot_party_type, spt_patrol), #tocan check
                    (party_is_active, ":patrol"),
                    (remove_party, ":patrol"),
                    (party_set_slot, "$g_encountered_party", slot_outpost_patrol, 0),                   
                (else_try),
                    (party_set_slot, "$g_encountered_party", slot_outpost_patrol, 0),
                (try_end),   
                (change_screen_return),
             (else_try),
                (lt, ":gold_amount", 500),
                (display_message, "@You don't have enough money to demolish the outpost!"),
             (try_end),
            ]),