Need More Info Online is lagging despite stable fps

Currently viewing this thread:

Version number
e1.5.9
Branch
Main
Modded/unmodded
Unmodded

Deluded

Recruit
Summary: I'm getting a relatively stable 60 fps capped at 60 otherwise it's in the 60-100 range. No matter the graphic settings, medium, low or the lowest possible settings, I'm getting a fairly stable fps between 55-60 yet I still experience stutters and lags without even getting fps drops. I get this in online and singleplayer. It makes the game unplayable and I've more or less had the problem from the start although it is occurring much more now than it used to before. I'm not sure if this could be because of my specs or problems with my fans not being sufficient enough but I've tried every possible solution to no avail. The game runs perfectly fine for 10-20 seconds before I experience lag spikes and stutters both in SP and online, it just keeps going on like that and I was wondering if anyone has an idea what the problem might be.
How to Reproduce:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Win10 64bit
GPU: RX 580 4 GB
GPU Driver Version: Software Version 2020.0821.1329.24282
CPU: i5-7400 3GHz 4 cores
RAM: 16 GB
Motherboard: PRIME B250M-A
Storage Device (HDD/SSD): HDD
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
 

Deluded

Recruit
We have a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send us your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please left a reply to this thread with the download link.
Hate to be a pain but the upload function is simply not working, I have been trying all day to upload. the file is 256 kb.
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
tmcap file is 256 kb? That looks really small in size. You can upload it to any other site and send us a link if you experience any issues using our site.
 

Deluded

Recruit
OK, replying in case anyone is experiencing similar problems. Low graphic settings seemed to be the issue causing more lagging. The lower settings I was playing with both SP and MP, the worse the lagging was. I updated my graphic card drivers and raised the graphics to medium settings. With updated drivers and low settings, my game was still lagging horribly. Higher graphic settings stabilized my overall performance even though I still experience mild lagging but it is now stable enough to be able to enjoy SP if not completely MP.
 
Top Bottom