ON HOLD - Pike & Blade Merged v3.3.2 (Needs to be updated to 1.143/DP 4.1)

Users who are viewing this thread

Kogara

Sergeant
M&BWB
I have even seen that other lords automatically transfer over to me because they are mad at their king.

Nice.

"My Kings an ass, mind if I hang with you instead?"

....Just felt like commenting on that. *Carries on with other tasks*
 

Waihti

Knight at Arms
WB
ellwoodis said:
(It would be nice to know why the attempts failed:grin:id the Lord not want to talk and would a future emissary mission be fruitful?)

It's planned to improve the information the emissary gives you in a later version of Diplomacy.

ellwoodis said:
I seriously would pay good money to someone who can solve this and make recruitment of foreign Lords more realistic and practical.

you wanna pay cash?  :grin:
 

Kogara

Sergeant
M&BWB
Ok, so now I've had few people come to me with "problems" only to have it turn out that its because they're still using patch version 1.127.

I have it listed that version 3.0 of the merge requires 1.131, once in plain text in the news section, and a second time in bold right next to the link....:roll:. Apparently this isn't enough lol.

So, to avoid anymore confusion, I'll state this once more, *ahem*......

THE 3.0 MERGE REQUIRES PATCH 1.131!!!!!!!!


[/rant] (Yeah, I felt like using brackets)
 

Onasaki

Veteran
M&BWB
Hey, I got a minor bug. It's not gamebreaking or anything, but I'm getting an AI error:

Code:
SCRIPT ERROR ON OPCODE 1641:
Invalid Party ID:1374;Line No:181:
At script: party_set_ai_state
At script: party_set_ai_state

It's a common error, and I've seen it before in other mods. But I thought I'd post it here, just to be safe.
 

Tokashi

Veteran
WBNW
I think it is not part of Pike and Blade but its Diplomacy, I have never seen that error. I have no idea what it is about maybe post it in the bug report in the Diplomacy forum.

Pike and Blade only uses 3 txt files. Troop, party_templates and item_kind1
 

Kogara

Sergeant
M&BWB
Yes, its probably Diplomacy or Native related. As Tokashi said you should probably stop by the bug report thread for Diplomacy or just Native.
 

Tokashi

Veteran
WBNW
While I am playing again (after 3 weeks of hard programming and work for my final year project), Cataphracts should actually have the new Sarranid Armoured horses, maybe we should update that for the next Diplomacy Merge ?

The have currently the  Heavy Chargers...

What do you think about it ?

It is just for the looks I think ? :wink:
 

realwiz

Regular
WBNW
Tokashi said:
While I am playing again (after 3 weeks of hard programming and work for my final year project), Cataphracts should actually have the new Sarranid Armoured horses, maybe we should update that for the next Diplomacy Merge ?

The have currently the  Heavy Chargers...

What do you think about it ?

It is just for the looks I think ? :wink:
Good thinking. The devs didn't include the horses for nothing, did they?
 

Kogara

Sergeant
M&BWB
Yeah, if you'd like go for it, test it all out to make everything is OK balance wise and whatnot. I've been meaning to do it since they added them but haven't gotten around to it  :???:. If you do, just shoot over the updated file(s) to me. Oh, and make sure the stats are ok on the new horses, I can't recall....
 

Kogara

Sergeant
M&BWB
No its not updated yet, I just now got around to check for updates as I've been very busy today. Expect a release within the hour. (As of 9:37PM CST)
Update postponed, see News in OP for details.


P.S. For future reference, the version number of the merge is directly related to the version of Diplomacy it uses. (i.e. Merge version 3.0 uses DP version 3.0, and so on)
 

Kogara

Sergeant
M&BWB
Update to 3.1 inbound, file is being uploaded and I have to edit the OP, but after that we're good to go.

PLEASE read the news section after I've uploaded the link, there will be some important information related to what was wrong.
 

Jedar

Recruit
Ehm i have a problem, just fresh installed Diplomacy + Pike & Blade, with old savegame, it runs fine i think, but, i can't just start a new game and don't know why. Sorry to bother :smile: i will try to get it works, i haven's tried nothing. I wanted just warn about this problem.  (ob patch 1.131, vanilla runs fine and diplo 3.0 + Pike & blade run fine also, problem are with 3.1)



like i said there : http://forums.taleworlds.com/index.php?topic=131243.new#new

I also have this bug. caused i think from Diplomacy mod o Pike & Blade. With Native no problem, but when i just open the game with new diplomacy mod 3.1 merged with Pike & Blade Mod, i can't start new game, only load old game, with they works perfectly :smile:  Strange..


EDIT : Ehm solved :smile:  the problem is in the savegames. Don't ask me why, but i tried renaming the dir "diplomacy" in "Diplomacy new" and i can play and start new game as usual. but if i take savegames from diplomacy, and copy them on savegames diplomacy new dir , problem is still here. So i think it's not the mod but something from previus savegames and new savegames. so. the important thing is that i can play with older savegames and with some tricks start a new game :smile:
 
Thanks for all the work! This is my favorite mod at the moment and I really enjoy the new possibilities it offers.

Cheers,

Gerard
 

Kogara

Sergeant
M&BWB
@Gerard: Hey no problem man, its my favorite too. Glad you enjoy!


@Jedar: No idea how or why this happened to you, but I'm glad to hear you found a way to make it work  :???:
 

possum

Knight
WB
a bug:

i got knocked out in a battle, my troops managed it to win but i could not end the battle. i got no "press tab to leave" message and when i pressed it anyway i got the message that i can not leave because of the "enemy near" message. i had to quit the game and lost a great victory :sad:

EDIT:::::........

one more thing: once started, i cant stop a village raid. this forced me to fight a battle i wouldnt fight otherwise.
 

Jedar

Recruit
possum said:
a bug:

i got knocked out in a battle, my troops managed it to win but i could not end the battle. i got no "press tab to leave" message and when i pressed it anyway i got the message that i can not leave because of the "enemy near" message. i had to quit the game and lost a great victory :sad:

EDIT:::::........

one more thing: once started, i cant stop a village raid. this forced me to fight a battle i wouldnt fight otherwise.

I had this problem only some days ago, when a strange vaegir horseman started to run to all map and don't attack. Enemies were all infantry and can't get him sliced :grin: , i had to alt f4 .
Luckily i don't have those problem anymore, fresh installation , patch and mod, started a new game, no problem :smile: , but 1 thing, why if i die i have to wait the end of the battle and can't press tab to autoresolve? It is normal that i can't retreat because this "enemy near" ? 
 

possum

Knight
WB
Jedar said:
possum said:
a bug:

i got knocked out in a battle, my troops managed it to win but i could not end the battle. i got no "press tab to leave" message and when i pressed it anyway i got the message that i can not leave because of the "enemy near" message. i had to quit the game and lost a great victory :sad:

EDIT:::::........

one more thing: once started, i cant stop a village raid. this forced me to fight a battle i wouldnt fight otherwise.

I had this problem only some days ago, when a strange vaegir horseman started to run to all map and don't attack. Enemies were all infantry and can't get him sliced :grin: , i had to alt f4 .
Luckily i don't have those problem anymore, fresh installation , patch and mod, started a new game, no problem :smile: , but 1 thing, why if i die i have to wait the end of the battle and can't press tab to autoresolve? It is normal that i can't retreat because this "enemy near" ?

that is a different problem. you had one enemy left on the battlefield, i killed all of them (my troops started the "cheer" animation) but was not able to end the battle.
 
Top Bottom