In Progress Not sharing food while under siege

Users who are viewing this thread

Version number
1.7.1
Branch
Main
Modded/unmodded
Yes, I used mods.

Steel Blood

Recruit
Summary:
An allied army retreated inside an allied castle while being chased by a larger enemy force. While under siege, the garrison and militia had plenty of food, but the army ran out. The garrison however did not share any food and the army inside starved to death. I cannot call this anything other than a bug unless the garrison stepping over the starving corpses of their allies on their way to lunch is for some reason intentional. My party also had food, but the army disbanded inside so I could no longer share it. I tried talking with the lords to trade them food, but there was no option to trade or talk while we were under siege. I reloaded to right before the siege, was able to trade, and trading food wasn't even an option. No matter what I tried, the army starved to death while surrounded by food.

How to Reproduce: Be inside army with no food inside settlement under siege.
Have you used cheats and if so which:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: 2070 RTX
GPU Driver Version:
CPU: i5 7600k 3.8 Ghz
RAM: 16GB
Motherboard:
Storage Device (HDD/SSD):
 
Last edited:

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, as far as i know, the food of the settlement is for the garrison and militia. Altough, i have informed the devs about the issue. Thank you for reporting it in.
 

Khornet

Recruit
This works both ways by the way, the issue of not being able to resupply starving settlements/castles with your own food is ancient. I don't know if it's intended, but if it is, it's kind of stupid.
Only armies are allowed to share.
 
Top Bottom