In Progress Non mounted Companians count as mounted and mess up spacing of formation

Users who are viewing this thread

Version number
1.7.0
Branch
Main
Modded/unmodded
No, I didn't use any mods.

GaMoR

Recruit
Summary:
Since I was captured and all my Companions were lost, something went wrong with their formation identity. After I get all my Companions back. I gathered again some troops and then it started, that my infantry formation had all the time the spacing like they would be mounted. It has a connection to my companions (see below) and this bug can go over to other formations if you assign one of the "messed up" companions to ranged it will happen to range as well (after one fight -> it does not happen immediately).


After plenty of testing something is messed with their formation identity after they got captured. Because if you unmount (remove horses in the inventory) all companions it works fine again if you mount all it still messes up the formations, they aren’t even a part any more. I can’t investigate deeper because I’m not skilled enough to look in the code.

I’m uploading parallel a save file.

How to Reproduce: Start a battle (with my Save file) 1 Formation spacing not working properly. Put all Companions in the City -> Formation spacing working proper, remove all Companions horses -> Formation spacing working proper. Just give back horses to the Companions like my original assignment and it mees up again spacing in formation 1. If you play with captains around and assign a “messed up” one to formation 2 the spacing of formation 2 will be messed up as well.
Have you used cheats and if so which: no none
Scene Name (if related):
Media (Screenshots & Video): Computer Specs:
OS:
GPU:
GPU Driver Version:
CPU:
RAM:
Motherboard:
Storage Device (HDD/SSD):
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Balbor

Recruit
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
I have also had this problem in 1.7.0. The companion causing the problem is one called The Wainwright (Vlandian Engineer). Dismounting the companion fixes the issue. Even though she is assigned as the cavalry captain she appears to be effecting the infantry unit. During the set up phase I can assign the infantry into another free group (5-:cool: and this temporarily fixes their spacing, however at the start of the next battle both group 1 and 5 will be bugged.
 
Top Bottom