Resolved No sound, game crashes at options

Currently viewing this thread:

Version number
e.1.5.7
Branch
Main
Modded/unmodded
Yes, but I removed mods.
Dump identifier (optional)
2021-02-10_14.59.19_c7ef212e3b9d6691507213538dc3c18d

proudlimey

Recruit
M&BWBWF&SVC
This morning, after no problems at all, my game suddenly starts with no sound. When I try and click on options in the main menu (or in game), the game crashes.

I can load games fine, but there is still no sound, and eventually it crashes.

I find this bizarre, as only 2 days ago there was a hotfix stating that crashes were fixed when clicking main options with RTX card, but I played the game fine yesterday.

The only thing I can think of that changed is hardware related. I had been daisy-chaining one power cable into my new 3070 card, and decided to change that this morning and plug two separate cables from my PSU. I can't for the life of me think how this would negatively affect Bannerlord (other games work fine), but as I say, it is the only thing that has been changed.

I've tried reinstalling the game, and have downloaded the Beta, and then revered back to 1.5.7 (as one post had suggested) but there has been no change. Any help would be much appreciated.
 

proudlimey

Recruit
M&BWBWF&SVC
I seem to have found a fix.

In the engine_config.txt file I changed sound_device from 0 to 1. So far it works, but the sound option in the options menu seems to start with the wrong selected sound, meaning I need to change it everytime.

Obviously the daisy chaining had nothing to do with it, but I did knock off the HD Audio motherboard cable while re-jigging it. Perhaps plugging it in again messed things up? No other games were affected though.

I guess this can be classed as 'resolved' now, although obviously not ideal.
 

1tjordons

Recruit
I've changed the sound device to 1 but my game still crashes everytime i try to go to options. Was that all you did to fix it? Any tips would be greatly appreciated
 
Top Bottom