Resolved Scene Editor Navigation Mesh - Generate Grids Crashes Larger Scenes with outermesh

Users who are viewing this thread

Version number
1.5.2
Branch
Main
I tried generating a grid mesh on a scene that was 15x15 100 density, and the game would hang up (not responding in the title bar, turns white when you click on it) even with grid sizes of 25. Even leaving it for several hours I wouldn't get mesh generation. I finally increased the size of the grid to 100 and it was generating OK, but I noticed that the mesh was extending far beyond the borders of the scene, so I removed the outer terrain layer, saved, and reloaded the scene. At that point I was able to generate grids of size 5 without too much trouble, and I am trying size 1 as I type this.

I think the game is trying to cover the outer terrain prefabs with navigation mesh and it's crashing the editor.

Let me know if you need more info.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Are you still experiencing this issue?
Were you able yo use the crash uploader after the crashes? It is nearly impossible for us to reproduce most of the editor crashes. With an uploaded dump file of the crash, we can debug the issue. If you are still experiencing this issue please use the crash uploader and send us the crash identifier so that we can find it. You will see the identifier after the upload is completed and you can copy it on the dialogue window.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
I've been informed that this bug is fixed and the fix will be sent to the game with future patches. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom