In Progress Multiplayer - Extreme Lag Ever Since New (better) Router, but No Problems with FPS or Ping

Users who are viewing this thread


So I used to be able to play multiplayer perfectly, until two weeks ago when I got a new router. The router itself is way better than the old one, which was overheating and causing ping spikes in connection since it was like ancient, and with the new one I am able to play every game I have with way less ping, except for Warband multiplayer.

The easiest way to explain the lag would be that, it seems like there is a sudden ping spike, as I start phasing through people and everyone runs in one direction. But my internet is completely fine, I can still talk with my friend over discord in the background without problems. Also, my ping is completely stable when I look at the TAB screen, and my friend confirms that it never spikes even during the "lag spikes". So the game is telling me I have no ping, while I'm surfing around in a wobbly manner and eating attacks someone is throwing from 5 miles away.

This happens in any game mode, any time of day, any server and even after I restart my router etc.

No problems in singleplayer.

I tried reinstalling, moving the game to my ssd, different modules with mp, scan for viruses (which showed up my pc is clean) and fiddle around with some options. None worked so far.

Also, I just had the idea of connecting my mobile data to my PC to see how that works and it had the same issue...? I have no idea why this game is suddenly going nuts, but I am confused.

My pc specs are way more than good enough to run the game, at least it was until 2 weeks ago.
I can upload how the lag looks in action if anyone even wants to bother trying to help me with this mess.

Geforce 1650 Super
8GB ram
i3 10100F Intel CPU
64 bit Win10 Pro (up-to-date)
Game downloaded on SSD
Top Bottom