Resolved Mount & Blade: Warband game won't start.

Users who are viewing this thread

Neweko

Recruit
Summary:
Hello, I bought "Mount & Blade: Warband", about 2 years ago, and now after 2 years I rediscovered it so I decided I wanted to play it. So I installed it on Steam (I bought it for $20 on Steam) and once I tried to launch it, nothing happened... So I tried restarting my PC, then starting it, but that didn't work. So next I tried reinstalling it on another harddrive, but that didn't work... So after that I tried installing the game from the website (here) but that didn't work.... anyway, I've tried so many things but the game doesn't start...
How can I fix this?
How to Reproduce:
Try starting the game.
Have you used cheats and if so which:
Nope
Scene Name (if related):
Game doesn't even show anything, I click on it and after waiting 10 minutes nothing happens.
Media (Screenshots & Video):
Nothing to show, the game just doesn't start. (I've tried running it as administrator)
Computer Specs:
OS: Windows 10
GPU: RX 570
CPU: Ryzen 7 2700
RAM: 16GB
Storage Device: 1TB M.2
* I've tried installing different versions of the game but that didn't work.
 
Top Bottom