Mount&Blade Cartographer | Just my own spin-off...

Users who are viewing this thread

Swyter

Grandmaster Knight
M&BWBWF&S
I'm going to need more details. Try first with an original module_parties.py / map.txt and if that works then you can narrow it down. I haven't changed the program since 2014, so I don't think it's been due to updates. :party:
 
Last edited:

Michadr

Grandmaster Knight
WBM&BVC
I'm going to need more details. Try first with an original module_parties.py / map.txt and if that works then you can narrow it down. I haven't changed the program since 2014, so I don't think it's been due to updates. :party:
When I right click on a party, it highlights, but won't move.
 
Last edited:

Swyter

Grandmaster Knight
M&BWBWF&S
When I right click on a party, it highlights, but won't move.
Even if you hold the G key while wiggling the mouse around? Does rotating with R work? If you upload your module_parties.py and map.txt somewhere I can probably take a look. But any details about what you've and haven't tried helps. At least editing the default files should work fine, out of the box.
 

Michadr

Grandmaster Knight
WBM&BVC
Even if you hold the G key while wiggling the mouse around? Does rotating with R work? If you upload your module_parties.py and map.txt somewhere I can probably take a look. But any details about what you've and haven't tried helps. At least editing the default files should work fine, out of the box.
It started working. Spend most of yesterday trying to figure it out. Thank you!
 

silvahiranya

Recruit
swyter please tell me how to get the latest version of cartrographer. I tried github but you it is archieved :sad:
please help me, im struggling without it. i registered to forums because of this.
 
Last edited by a moderator:

Swyter

Grandmaster Knight
M&BWBWF&S
swyter please tell me how to get the latest version of cartrographer. I tried github but you it is archieved :sad:
please help me, im struggling without it. i registered to forums because of this.

Earendil helpful as always. Thank you. :party:

I have recreated the original Bitbucket repository more or less from scratch to make all the original links (even the wiki/downloads) work again. Should be easier than changing every linked post on the Internet. I have also fixed the main post to fit the Xenforo bbcode markup. Have fun.
 

silvahiranya

Recruit
Earendil helpful as always. Thank you. :party:

I have recreated the original Bitbucket repository more or less from scratch to make all the original links (even the wiki/downloads) work again. Should be easier than changing every linked post on the Internet. I have also fixed the main post to fit the Xenforo bbcode markup. Have fun.
yep. i downloaded it. i set up msys parties path and mount and blade path perfectly. but when i try to run cartrographer cmd i get this.

Found MAB installation on <c:\Program Files (x86)\Mount&Blade>
Msys folder at <c:\Program Files\Mount&Blade Warband\Modules\Native\Msys\Module_system 1.171>
Module folder at <c:\Program Files\Mount&Blade Warband\Modules\Native>
@--start loading font xml
width:2048 height:1024 padding:5
font loaded in 0.016s
@--start loading font dds
SOIL DDS created a new texture with handle 1
@--start parsing map
ended parsing 0.285s
20791 vertex, 41387 faces
ended filling arrays 0.528s
ly:15.979083 lz:399.73822 lz wins! keeping coordinate system
@--start parsing parties
200 parties loaded... 0.008s
ground aligned in 0.712s
(i)no cache available, rebuilding displaylist
generated displaylist 0.421s
OpenGL Error: invalid enumerant
start traceback:
.\luagl.lua:7809: in function <.\luagl.lua:7008>
[c]: in function 'error'
.\luagl.lua:7923: in function 'checkError'
cartrographer.lua:384: in function <cartrographer.lua:184>
[c]: in function 'xpcall'
.\luagl.lua:7821: in function 'call_callback'
.\luagl.lua:7933: in function 'mainloop'
cartrographer.lua:545: in main chunk
[c]: ?


the cartrographer loads for few seconds and it closes.
any suggestions how to solve this?
 

Swyter

Grandmaster Knight
M&BWBWF&S
Strange, the problem with checking for errors after drawing is that it's hard to know which line is the bad one, the one with the invalid enumerant, I would need a better error callback to track it down. ¯\_(ツ)_/¯

If the error is non-fatal you can try opening cartographer.lua with a text editor, scroll down to the line 384 and add -- just before lujgl.checkError().

Save and restart the program, maybe that works as a stopgap solution. Let me know how it goes.
 

silvahiranya

Recruit
Strange, the problem with checking for errors after drawing is that it's hard to know which line is the bad one, the one with the invalid enumerant, I would need a better error callback to track it down. ¯\_(ツ)_/¯

If the error is non-fatal you can try opening cartographer.lua with a text editor, scroll down to the line 384 and add -- just before lujgl.checkError().

Save and restart the program, maybe that works as a stopgap solution. Let me know how it goes.
it worked! oh thank you!
 
I think you need to split the meshes by material type, or into material groups. I show the important OBJ export settings in a Blender screenshot. It's been a while and the Blender interface has changed a bit, but it should be easy to find the equivalent toggles.
Hi Swyter,
I am also having this issue with only plains exporting. I am using blender 2.93.1 and have used the recommended settings, splt the mesh by material, and experimented with various other toggles with no success. Do you have any suggestions what else i can try? thanks
 
i managed to figure it out how to export from blender 2.8 to cartographer. it is an issue with blender 2.8 due to how it imports, this issue doesnt happen for 2.7.

To use blender 2.8 you need to do these steps.
1. import map object
2. go to edit mode and select all, then separate by material
3. rename each isolated material to only the name of their material, as well as the submenu and the material itself. The materials are the 10 options (plain, bridge, desert, forest, mountain, river, snow, steppe, steppe_forest, water)
4. for each material in their "surface" section, disable "Use Nodes"
 

Swyter

Grandmaster Knight
M&BWBWF&S
Right, makes a lot of sense. I took a look and importing the Wavefront OBJ like this in Blender 2.92.0 seemed to work:

vKK6aIX.png
zC8z6jJ.png


Basically, don't split. After that the materials showed up correctly and I could assign them to the mesh with the (C selection keybind as I show in the guide).

8SseY5K.png


After that I tried toggling various Blender Wavefront OBJ export checkboxes and it essentially worked every time, no matter what I tried to mess it up.

But, in any case I recommend these settings, I believe my importer only cares about Write Materials (that's the important bit, otherwise you will get a pure plains/green map) and Triangulate (otherwise raw quads will appear with holes), Keep Vertex Order makes text diffs tidier, but it's not a big issue. Write Normals doesn't do anything because they get discarded (the game and the editor regenerate them from the triangles at runtime), same for UVs:


EQpag1S.png
HemY7XV.png
wBIW7hY.png
 
Last edited:
Hello, Swyter. Could you please explain how to fix the "Oops looks like we have a bug over there" thing, because I couldn't quite catch the potential fixes you wrote in the previous pages. If you could please explain it again I will be very grateful. Thanks in advance.

Found WB installation on <C:\Program Files (x86)\Steam\steamapps\common\MountBlade Warband>
Msys folder at <C:\Module_System>
Module folder at <C:\Module_System\DEUS VULT!>
@--start loading font xml
luajit: .\mab-font.lua:22: bad argument #1 to 'lines' (C:\Module_System\DEUS VULT!\..\..\Data\FONT_DATA.XML: No such file or directory)
stack traceback:
[C]: in function 'lines'
.\mab-font.lua:22: in function 'load'
cartographer.lua:46: in main chunk
[C]: ?
_________________________
Oops, looks like we have a bug over there :smile:
Press any key to continue . . .

Here's my module_parties.py directory:

I will provide anything if you need it. Again, thanks in advance.
 

Swyter

Grandmaster Knight
M&BWBWF&S
Seems like the program is trying to load the font files (first from the mod folder itself, if any, and then from the main game folder).

In your case the module folder is set to C:\Module_System\DEUS VULT!, looks like there is not a Data\font_data.xml + Textures\font.dds in there, so it tries going two levels up (your mod folder should be inside of the Modules folder at <game-root>\Modules\DEUS VULT!\FONT_DATA.XML) to grab it. Because the game doesn't seem to be there it errors out and stops.

So, that's the problem. Either edit your module_info.py to point to somewhere like C:\Program Files (x86)\Steam\steamapps\common\MountBlade Warband\Modules\DEUS VULT! or do it the other way around, like TLD, and have the module system folder inside of the normal mod folder and just set it to a relative path like (..). With the mod inside <game-root>\Modules (or for more advanced users; symlinked with mklink /J "c:\wb\modules\<your-name>" .. A folder junction or symbolic link is like a transparent shortcut for a whole folder, the exact same file shows up in two places).

Hope that helps.
 
I export my compiled txt files to a separate folder. That's why it detects it to the DEUS VULT folder. I will change it to the actual mod directory. If i paste the module system in the mod folder and then set it to the DEUS VULT separate folder will that work ? Btw thanks for responding!
Here's a screenshot of what I meant in the second sentence:
 

Swyter

Grandmaster Knight
M&BWBWF&S
The easiest way probably is copying the game's Data\font_data.xml and Textures\font.dds into your mod's folder, that should be enough for cartographer to ignore the (unreachable) game's font. There's also the self-contained way cartographer comes configured when you unpack it, you can just replace some extracted local mod/module system folder example files, edit the map and copy the edited files back.

But yeah, ideally you'd just export into a mod folder that the game can actually load and that cartographer can actually access.
 
Oh, right. Didn't think of that. I will do that right now. Thanks for the tips. Nvm, pasting the font_data.xml and the font texture didn't work.
 
Last edited:
Hello everyone, hello Swyter. First of all thank you for this incredible editing tool, glad to see people modding Warband these days, hope Im not too late lol. I have downloaded the module system and managed to set it up, yet when I download the Cartographer, my Norton Antivirus blocks the registry.dll file, saying it detected a heur.advml.c type virus, which it immediately quarantines and then asks to delete... sadly Im too much of a noob to identify if its just a false alarm... Do you think its just me and my antivirus being a little bit sch*zo ? ( severalof them in my family ), or do you think something might have snuck though the download site?
 
Top Bottom