Unresolved Mount and blade warband starts on steam but then nothing happens.

Users who are viewing this thread

MrJoeJoe

Recruit
Hi Guys

I'll press the play button for Warband on steam, it then says I'm playing but the screen those choose viking conquest, warband, napoleonic etc doesn't even pop up and so I'm unable to play the game. I've tried basically every method I could find online: Making sure my drivers and windows was up to date, enabling direct X, disabling firewall etc and nothing seems to work, so I just wondered if there was any idea on here.

Any help would be much appreciated
 

Eärendil Ardamírë

Subforum Moderator
WBWF&SM&B
Try if one of these two solution is working out for you, start with the bottom one:
Hello there! use this patch for Windows10-11, Warband cannot support new Systems

Open and select warband.exe and patch! Thats it.

Regards,
Ethred
Hello all!
BLUF: I believe this problem is caused by OneDrive and the solution lies in making sure the savegame and user profile data is saved on the local device.

Details: I've finally cracked this code (for me, anyway). I had this exact same issue, and found someone who recommended to re-install Windows 11. I did, and it worked, but only for a short time before it went back to the same exact issues - no window, no program, just hung in the launching sequence. Then I tried finagling with my savegame files and user profile data, deleting both, and lo and behold it worked again, just in time for it not to work again.

It occurred to me later in a flash that the only difference was me turning onedrive off and on. Essentially, the savegame and profiles were being saved in the cloud, but when I shut off onedrive and removed it from my startup sequence, then the data was trapped in the cloud while still having a semi-valid filepath. Thusly, MB would launch but then get stuck when there was no data to pull from.

I right-clicked the files/data and chose to save to local machine and it's worked flawlessly since then.

I really hope this easy solution helps the community! I've seen a huge rash of these problems which had the same exacty symptoms as mine, but with no real solution.
 

Eärendil Ardamírë

Subforum Moderator
WBWF&SM&B
@Crysix reported that he has solved that issue by changing his Documents(in OneDrive) path name in the Location tab. It was not written in English so he changed it to English (to "Documents") after the final backslash(/), saved and now M&B work with steam again.
unknown.png
 

Pandorian

Recruit
WBNWVC
I have similar issues. To actually see my launcher I had to change the first_time variable located in rgl_config from a 1 to a 0.

Now when I click Play Mount&Blade from the launcher, the process starts but no new windows opens. Windows says it is running as a background process.
I tried to click on Configure in the launcher as I've seen suggestions to do that if the window doesn't run but the launcher then freezes up.
If I click cancel instead of play or configure the background process starts to run and I have to kill it via task manager.
This process and results happens whether I use the standalone or the steam launcher.

I've tried that WarbandPatcher and it doesn't help either before I change the first_time variable or after.
EDIT: I don't have OneDrive installed and I never have had it installed.
 
Top Bottom