• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Morgh's M&B WB/WFAS Editor v1.50

Users who are viewing this thread

Wlodowiec

Sergeant at Arms
criffel said:
Here's my issue.  So I'm editing existing troops and not trying to create new ones.  I update, save, and start a new game.  Nothing has changed.  I check the troops.txt file and everything is the same as if I haven't changed anything.  I reload the editor and its showing everything as I left it, all troops have been edited and changed.  I'm not sure why the .txt files are default but the editor shows different.  Any ideas?

Windows 7 64 bit
M&B WB 1.143

Exactly the same problem... And as I see no one has solved it yet. Help please? Would be really appreciated.
 
I've spent at least 6 hours on renaming every troop in the Floris Expanded Tree whom wasn't in english and given all lords, ladies, rulers and companions a family name.

After all that I started a new game for I tried loading a previous save which did not have my changes which I already figured. Everything went fine until that intro ambusher bandit in the town attacks me and exactly the second he dies the game crashes over and over again.

I did a test with another troops.txt and renamed 1 lord, lady, companion and king etc to see if perhaps one of their category was the issue but it didn't crash.

I also attempted to go into the journal during that ambush thingy and thought of checking the charaters tab to see if any name was there and no... everyone was renamed "0". AND crash.

Help? Or have I wasted all this time for nothing?
 

lsok

Recruit
Im really bad at these things so ill try to explain what i want to do and see if someone manage to explain for me.
I would like to get an item from ACOK v2.2 to ACOK 3.0, what do i need to do to get it to work?
really appreciate some help.
 

NameHere

Recruit
Morgh said:
Welcome to Morgh's Mount & Blade WB/WFAS Editor - official thread!

Current version is v1.50

This tool supports powerful editing of TXT compiled files AND ALSO the Python module system!


Python module system editors (Warband only!):

- module_items.py
- module_troops.py
- module_party_templates.py

Compiled TXT editors (Warband / With Fire And Sword):

- troops.txt
- factions.txt
- parties.txt
- party_template.txt
- item_kinds1.txt



Official Editor Page (with download link)

Official Editor Documentation

Official Editor FAQ Page

Download Page


Latest changes:

v1.50

General changes:

- Extended compatibility, troop and item editor can load more community modules
  for example: "The last days of the third age"

Text item editor changes:

- Added flags to be compatible with Module System v1.165:
  itp_covers_hair
  itp_force_show_body
  itp_force_show_left_hand
  itp_force_show_right_hand
  itp_cant_reload_while_moving_mounted
  itp_has_upper_stab
  itp_kill_info_mask

v1.40

Text item editor changes:

- Added WFAS v1.143 flags:
  overswing_spear  = 0x0020000000000000
  overswing_musket = 0x0040000000000000
  thrust_musket  = 0x0080000000000000

- Marked the special WFAS capabilities and flags with " (WFAS) " behind their names

Module Sytem item editor changes:

- Removed WFAS flags, because the module system editor is only for M&B Warband!


v1.39

General changes:

- Module System editor is for Warband only!

Text / Module System item editor changes:

- Added v1.143 flags: itp_is_pike, itp_offset_musket, itp_no_blur


v1.38

General changes

- none

Text item editor changes

- Added multiple trigger handling (support now up to 5 triggers). I totally forgot that, so modules using items with more than one trigger (for example Brytenwalda: itm_torch) wasn't handled correctly by the editor. Saved item_kinds1.txt was damaged.

- Added code which identifies empty lines between item factions and item triggers. Now also item files from modules like Brytenwalda or Floris Mod Pack are loaded correctly. When saving item data, the empty lines will be removed, so the new file size is a bit less than the original.

- Reorganized whole form: Factions list is now bigger than before, also the trigger field. Lists have been reduced in height.

- Changed label above the item list which shows the count of items. It displays the count of items without entry 0: itm_no_item

And the last change, which will makes a few people happy:

- Item editor now fits better into 1024x768 screen size (without start menu - just set this to fade out, if you use the editor!)


v1.37

- Raised program version to Warband / With Fire & Sword v1.143

- Fixed a simple but annoying bug while loading the map_icons.txt to the "combo box" at the text parties editor. The Fire and Sword addon has a few map icons using two lines which was ignored by my editor. This was resulting in shifting up the other icons in the list by one position, so the parties has been shown the wrong map icon.


v1.36

General

- Changed program name to "Morgh's Mount & Blade WB/WFAS Editor"
- Raised program version to Warband / With Fire & Sword v1.142
- Fixed a few minor bugs
- Added html links (to the RAR archive !!!) to the quick documentation and FAQ page


v1.35

General

- Fixed a couple of bugs, also at party templates editor (problem with just added new troops)

could I get a download link to your map editor all the ones ive found Norton wont let me run them
 

Alvagor

Recruit
Hello, I got a problem with this tool: I added some weapons successfuly to the game (soldiers use them because I set them to use these weapons), but strangely I can't make them appear in shops... and yes, I already turned on the "Merchandise" flag and increased the "Abundance" value. I passed literally hours to try to resolve this problem and I even tried to untick all the modifiers (if it could be relevant) and even ticked and unticked various checkboxes in the "Faction" tab of the item editor. Is there someone who could tell me what I'm doing wrong? :sad:

P.s. I told to the editor to work with the .txt files, if this could be relevant.
 

Halbedier

Recruit
I noticed that some units have F in Ironflesh, B or C in Powerstrike. I assume that these are values for above 10 skill level, but how do I make other units have lets say Ironflesh 15? It won't let me write a letter in and just writing 15 will change to 5 after updating troop.
 

Halbedier

Recruit
hubertis2001 said:
Hi ,
How add item on Singleplayer character in morgh's editor ??

I would use in-game cheatmenu for that. Just use morgh's to find IPs of items.

You can edit player troop (ID 0), but that seems to be default model for every character and I'm not sure what editing that does to the game.
 

Ulticane

Regular
What exactly is courage in the parties menu? The higher the courage the more likely the party will chase enemies? I can't find any information on this.

I set a party to 15 thinking this and now it won't chase anyone at all.
 

Midnitewolf

Sergeant
Dumb question and one likely answered somewhere in the 160+ pages of this thread but it I just wanted to add one or two new troop types to each faction in someones Mod, is it really as easy as clicking "Add Troop" then selecting its place in the upgrade tree, adding skills and equipment and hitting save or is there more too it than that??
 

Halbedier

Recruit
Midnitewolf said:
Dumb question and one likely answered somewhere in the 160+ pages of this thread but it I just wanted to add one or two new troop types to each faction in someones Mod, is it really as easy as clicking "Add Troop" then selecting its place in the upgrade tree, adding skills and equipment and hitting save or is there more too it than that??
It is that simple. Just make sure the unit is placed in correct faction and has correct race (skin menu under flags).
 

Dead Child

Recruit
Is it possible to edit an item to make it invisible? For example, a helmet. I'm not seeing an option to do it anywhere in the tool, but a few posts on google hint that it is in-fact possible. I'm just missing it. Helmets are dreadful. D:
 

Horcerer

Baron
WBWF&SNWVC
Use openBRF. Get a "blank" model, name it the same thing as the original helmet's mesh name, then replace the original helmet with the blank. I suggest a backup copy.

Or just replace the mesh name listed in Morgh's with a few random letters, though you'll get an (non-intrusive and non game breaking) error message whenever the helmet is loaded.
 

Morgh

Recruit
Whatever happened to my forum account  :evil: - I think I was trying to change my eMail Adress some months ago... My homepage for the editor changed. But as new user, I cannot even post a full homepage link...

terrafluxus.net/morgh/pages/morghs-mb-wbwfas-editor

May the moderator change this please in the first post of this topic. I can't do that anymore. And maybe also restoring my account!?

Thank you.
 
Maybe someone else figured it out or already said by, but when trying to edit certain troops (bandits mostly) there is and error something like "information overflow" or "#6 overflow". Then the troop is left nearly empty and sometimes copy paste info of another previosly selected troop,  I believe this is due the state of the items that were coded to be ragged, "ragged" state which makes the item of less quality and nor this editor nor the other has a way of editing the items that way.

Cheers thanks for the editor :smile:  :party:
 

adrakken

Sergeant
M&BWBNWVCWF&S
scar1981 said:
Download links do not work. Where can I get the last version?

This, download link is still not working. Cannot find another site to download from via Google, nor is it listed on moddb or Nexus.
 
Top Bottom