Resolved General Modding tool update today on launch tells me every game file in the game is “already in use” one file at a time

Users who are viewing this thread

Version number
1.5.2
Branch
Main

Lonewarrior

Sergeant
FOUND A WORKAROUND:
Deleting the folders (materials_andac and materials_omer) located in Native/EmAssetPackages/mat1 Allows the mod tool to be launched, but they must be replaced when launching the game or it might crash.

After today’s modding tool update when launching the modding tools, the launcher appears.
But when starting the game even with no mods ready to edit I get an error message 1 by 1 in alphabetical order saying that the games files are already in use, I gave up clicking ok at about 50 as it just goes on and on.
Game is version 1.5.2 and mod launcher is up to date with the update from today.

I have validated both the game and modding tools through steam and each said “all files validated” so nothing was needed to recover.

How to reproduce: launch mod tools
Specific tool: Modding tools launcher

EDIT: doesn’t happen 100% of the time.
It worked once, since then ive tried another 30-40 times with no luck.



AUswRps.jpg









Crash LOG:


[20:53:15.620]
CONTENT WARNING: Package item aserai_archer_armor already added from package $BASE/Modules/Native/EmAssetPackages/mat1/materials_omer/materials_omer.tpac.
[20:53:15.620] #[email protected]{4554970636A745A39B371F0802290354} (1): 0:18981
#[email protected]{4554970636A745A39B371F0802290354} (1): 0:23834
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:5804401
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:2677833
#[email protected]{4554970636A745A39B371F0802290354} (1): 0:125163
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:4500658
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:4495100
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:4491284
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:6075895
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:8750835
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:5764249
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:5763483
#[email protected]{7EF3923F663742E88571CB3884770DB8} (1): 0:5766823
#[email protected]{EE98F0843F40858DC51E8E564ADED5DF} (1): 0:136386
#[email protected]{89C3B9FD1C796A0F430E0CEF0646F003} (1): 0:94164
#[email protected]{01DEFFF845AAA742EA34488610D487CB} (1): 0:315073
-----------------------------------------------
No managed frames available.


There one error for every item in the game, but it’s tideous selecting submit an error for the 1000s of error messages.
 
Last edited:

Murat Türe

Developer
Did you copy any tpac's manually from the native folder? Did you have any changes regarding the resources in the native module?
 

Lonewarrior

Sergeant
Did you copy any tpac's manually from the native folder? Did you have any changes regarding the resources in the native module?

I haven’t edited those Files or moved them at any point if that’s what you mean.
I haven’t dont anything with the Tpac files except create a duplicate of the world map meshes (which I deleted the duplicates of when I realised I didn’t need to edit them to achieve my goal) but this error showed up immediately after the modding tools got their update, My workaround seems to be ok for now.
The duplicates I deleted were long before this error came up so I don’t think they are related.
The only other thing I can think of is that another mod is using those resources but I can’t pin it down to anything.
 

Murat Türe

Developer
If you do not have any changes in Native modules, you can delete the "steamapps\common\Mount & Blade II Bannerlord\Modules\Native\EmAssetPackages" and validate the game through the steam. Note that this will re-download a big amount of data. The error indicates that there are some duplicated files left in the Native module. Hope this fixes your problem.
 
Top Bottom