• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

In Progress General Modding Tool - DPI/Resolution Issue - Off-screen

Users who are viewing this thread

Version number
e1.5.2
Branch
Main

Bloc

Archduke
WB
Not sure if this is the right place to report this or not but I'm having issues with Modding Tool executable.

Problem:
The game that is run from Modding Tools is too big and therefore screen shows only a small part of this enlarged window. Same for both Fullscreen and Borderless Window.
When I set it to Window mode ( via config ) It gets off-screen and I have to do windows key tricks to dock it left or right and then resize. Even if I do that, closing and restarting yields the same issue.
The base game that is launched from normal launcher doesn't have this issue.

Screen Resolution:
Tried several resolutions but didn't work out. Usually, I play at 1280x720
My laptop desktop resolution is 3840x2160

What did I check?:
Apparently, both Win64_Shipping_wEditor and Win64_Shipping_Client executables are reading the same config from Documents/Mount and Blade II Bannerlord/Configs
Hence if I change one, the other game is also getting affected.

In engine_config.txt, if I change the line display_mode = 1to 0, it sets to window mode ( 0 = window, 1=borderless, 2=fullscreen) but then it runs off-screen and requires quite a bit hassle.

I'm guessing that something left out in executable for modding tools which creates this issue. Normally I would say that a DPI enforcing causing this issue but if this was the case, I think base game would fail to look normal as well - since it's not the case I think something is off with modding tool launcher.

Screenshots:
Both screenshots are from exactly the same settings and config
F0UKvq.jpg
OR0pWu.jpg




Solution until Taleworlds adds DPI Scaling Support
  1. Go to Win64_Shipping_wEditor folder.
  2. Find Bannerlord.Native.exe ( I only used this exe tho, not sure about the differences of others but you can do it for all )
  3. Right Click -> Properties
  4. Click Compatibility
  5. Click Change high DPI settings
  6. Check Override high DPI scaling behavior
  7. Select System ( not enhanced )
Now start the exe and there you have it.

Something like this
9odcBs.jpg
 

Bloc

Archduke
WB
I have exactly the same problem followed by an error in the steering part with the mouse
You mean exception box error? Or weird behaviour like error? Because when I CTRL+E and open Editor, Tools window, buttons etc looks fine ( although some buttons, information boxes are poorly scaled and not readable ) but holding right mouse button to rotate item causes camera to go bonanza and rotate like a rabid dog

If you have a different Windows UI scaling from 100%, that can cause these problems.
I have 250% by default and recommended by Windows. I also think that if I set it to 100% it might work but this also bugs up my entire desktop layout + other applications. It's not something I will set - not for an editor at least.
 

Bloc

Archduke
WB
Okay I found a solution without bugging up your other settings.
  1. Go to Win64_Shipping_wEditor folder.
  2. Find Bannerlord.Native.exe ( I only used this exe tho, not sure about the differences of others but you can do it for all )
  3. Right Click -> Properties
  4. Click Compatibility
  5. Click Change high DPI settings
  6. Check Override high DPI scaling behavior
  7. Select System ( not enhanced )
Now start the exe and there you have it.

Something like this
9odcBs.jpg
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom