M&B WB Napoleonic wars 1.21 Setup dosen't run

Users who are viewing this thread

kompassi

Recruit
Hi, I downloaded the latest M&B WB Launcher from this site and it works normally. When I run Napoleon Wars setup it fails and error "Warband has not been updated to the latest version"

WB is Version 1.174

Napoleonic is 1.21

It's surprising when I downloaded from this site and chose to download the latest ones
 
Back
Top Bottom