M&B Mod-Related Websites

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
Well, a few further updates to the site.
First off, the old links will no longer work as the Fenrisoft site has also moved to a new server, and I was unable to retain the database for the old repository setup through the move. All people with old download links (still pointing to http://www.fenrisoft.com/mb_repository/) should really update them as soon as possible. Of course after that you shouldn't need to update your links again for at least a year's time now, and probably not then.

Now then, slightly bad news. Well, not really bad, but mildly annoying. The new host of the site has now locked the PHP restrictions down on the server (I was sneaky and circumvented their original limits, bad me), so the PHP upload limits are back at 8mb. No worries though, I've added back the CGI script workaround to allow uploads of up to 100mb. It's also pretty thoroughly integrated in the upload submission process now, so it will ask you if the file is smaller or larger than 8mb and proceed from there.

I've fixed a couple of bugs as well. The autologin process (so you stay logged in if registered) was not working properly with direct "File Details" links for people with accounts on the site, this has been fixed.
From some other changes I made a while back it would not allow you to edit listings without uploading a new file, this has been fixed now as well. You can edit your entry at any point and change the description, category, M&B version it's for, and so forth without having to upload the file again.
There were a couple of other minor bugfixes as well.

I'll probably be doing a little more work on the site in the next few days.
 

codewright

Sergeant at Arms
M&B
Best answers
0
btw, you can safely remove the quote of mine you have in your first post. thanks for putting it there in the first place, but it seems like i don't really have enough time to compete with your site, which seems to do quite well :wink:
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
Alright, if you want it (or another M&B site for that matter) added back to the first post, just ask. :smile:

EDIT: I think I'll change this thread to "M&B Mod-related websites", and add in links to the other sites I know of as well. There's the Wiki(s), the Onin No Ran people's general modding forums... what other sites am I missing? If anyone wants a site added to the list, just post the link and preferably a short description to go with it.

The post will be more useful as a sticky then, as the other sites don't seem to have links handy in any other prominent place.

EDIT 2: It's done. Anyone with other M&B websites which are even remotely mod-related, post 'em here and I'll add them to the first post.
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
And of further note, I've just gotten through changing the way the Repository site functions a bit. Messages (such as "you are logged in", "file uploaded successfully", "Upload error: whatever", "thanks for your vote/comment", etc.) will now show up at the top of the left menu on the next page rather than transitioning temporarily to a page with the message displayed and then transitioning to the next. This cuts out a step which will speed up navigation of the site, and additionally allows you to see the message more easily since it is no longer just temporarily shown in a transitional page.
Now if you have an upload error, you'll be able to see why much more easily. :razz:
I know I was getting a little annoyed at the wait each time I went to the site and it logged in automatically, taking that extra time for the transitional page.

The messages showing up in the top left corner should get your attention fairly easily, as the coloring is nice and bright.

On another subject, I still would like to know if there are M&B mod-related websites I've missed so I can add them to the first post of this thread.

EDIT: reworked the Repository logo a bit, textured the text, and switched to lance and sword images of actual in-game weapons. I think the official M&B logo should use the sword and lance layout I came up with (lance under the word "mount", sword under the word "blade", evokes what the game is about). I know, the lance looks a little fugly from resizing. Maybe I'll tidy it up in the future. :smile:
 

guspav

Section Moderator
WBM&B
Best answers
0
hey there! the mesoamerican project mod has an independent forum (the thread was getting too big and complicated) the url is: http://vacuus.bur.st/UMBF/index.php
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
What, the background textures? That was pretty quick, I just very shortly ago added those since I got tired of the overly bland look.
Yeah, I like the new textures better myself. :cool:

EDIT:
Oh yeah, the site is obviously popular; last month's (January) bandwidth usage was 105GB. :eek:
Good thing it's got 300GB maximum monthly bandwidth.
 

dablade

Master Knight
Best answers
0
The logo looks nice, and so do the textures, nice work Janus.
Sometimes I have problems loading the page, it looks like it's on a load and reload loop for a while (with textures already loaded), and then it ends with an error (blank page).
Don't know why that happens.
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
Hmm, lemme guess, you're using Internet Explorer, right?
I was testing at one point in various browsers and had that happen in IE (except it eventually loaded the page). I normally use Firefox which has no such problems. After that though I checked the code and there is definitely nothing there which should cause a refresh. I tested the page further in Opera and Safari (MacOSX browser; I run OSX emulated on my PC :smile:), an had no problems out of them.
Went back to IE, problem still happened, but it seemed to quit doing it shortly after that. I thought maybe it was some strange temporary thing.

So, I guess it's just another instance of IE being screwed up. Having done a fair amount of web design, working around IE flaws (where other browsers display correctly) is a rather annoying and fairly frequent job. :mad:

I'll take another look at it tomorrow and play with the code to see if I can fix it.
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
Sorry for the Repository site downtime. It was down for a few hours since my host switched around the internal root path, which has to be set within a configuration file for the site software to find all of it's files. This is fixed now, and it's back up.

On the bright side, the site seems to be going a lot faster now from the move; hopefully it will continue to load this fast. :smile:
 

Dreadus

Regular
Best answers
0
http://ghorde.proboards46.com/index.cgi

golden horde forums, soon to be our public testing grounds.
 
Best answers
0
Is it only me or the Repository is down ? I keep getting this message since this morning (except once) :
XOOPS path check: Script is not inside XOOPS_ROOT_PATH and cannot run.

Edit : It suddenly does work now. :???:
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
That popped up yesterday when they changed the internal path of the website's files on the server like I mentioned earlier when I fixed it. Apparently very shortly ago they changed the path back, so I again had to modify the site's config. It's up again now.
Hopefully they quit monkeying with the damn path. :???:
 

Janus

*spicy* *camper*
Administrator
WBWF&SM&BVC
Best answers
0
Doh, would have added it already if I had thought of it. Adding it presently.

EDIT: There it is. If you want anything changed about it, just let me know.