• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

In Progress Loading a file -> spending influence -> pressing ESC resets your influence

Users who are viewing this thread

Version number
e1.6.5.291843
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

Grank

Sergeant Knight at Arms
WBNWVC
Summary: After loading a save file, spend influence in any way such as supporting a clan, and then press ESC. The number of influence you have will reset back. For example, if you have 2000 influence and support a clan twice (2x50), your influence will be 1900, but if you press ESC, the menu will not appear, and instead your influence will reset back to 2000. Practically this gives the player infinite influence. Does not happen if you interact with any popup like notifications or the "Solve this kingdom decision" popup.
How to Reproduce: Load the following save file, open Kingdom, support some clans, exit the Kingdom window back to the campaign map, and press ESC. This only happens once after loading a save. To exploit it, save after resetting your influence, then load the save file again, and repeat the process.
Have you used cheats and if so which:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: Don't remember
GPU Driver Version: Latest
CPU: Intel i5 gen 10 or something
RAM: 24GB
Motherboard: Forgot
Storage Device (HDD/SSD): SSD
 

CptMuppet

Sergeant
Hello! I have tried to reproduce this issue using the same game version and few my own different save files, but unsuccessfully every single time. However I was having lately issue with ESC not opening menu when pressed while being on the campaign map view. Unfortunately I didn't notice then whether it was doing something strange or not.
 

Grank

Sergeant Knight at Arms
WBNWVC
I have tried to reproduce this issue using the same game version and few my own different save files, but unsuccessfully every single time.
Perhaps it's related to perks? It's very consistent in my game. My game is Sandbox by the way, not campaign. Maybe there's a difference there too.

Other factors that might be worth looking at would be my daily influence gain and the kingdom policies (I proposed a lot of influence-related policies to be implemented).
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Grank

Sergeant Knight at Arms
WBNWVC
Hello! I have tried to reproduce this issue using the same game version and few my own different save files, but unsuccessfully every single time.
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
I captured a video for you guys over here. All I did when the influence reset was pressing ESC. As you can see, the menu didn't appear. Hope this helps.
 

CptMuppet

Sergeant
I am curious about one thing. Was your campaign played purely on the beta e1.6.5 from the beginning? Or do you started it on a different version of the game?
 

Grank

Sergeant Knight at Arms
WBNWVC
I am curious about one thing. Was your campaign played purely on the beta e1.6.5 from the beginning? Or do you started it on a different version of the game?
Yes it's pure. I always start a new campaign when I change version. Because I know it will cause random issues otherwise.
 

CptMuppet

Sergeant
Yes it's pure. I always start a new campaign when I change version. Because I know it will cause random issues otherwise.
Thanks for the reply. In my case the bug didn't happen on two different saves, as I wrote earlier, but I have used one save from campaign played on beta e.1.6.4, and one from campaign played on versions e1.6.0 and e1.6.3. It's strange that it seems to be purely beta e1.6.5 thing since I tested my older save files on the beta e1.6.5 just like you.
 

Grank

Sergeant Knight at Arms
WBNWVC
Thanks for the reply. In my case the bug didn't happen on two different saves, as I wrote earlier, but I have used one save from campaign played on beta e.1.6.4, and one from campaign played on versions e1.6.0 and e1.6.3. It's strange that it seems to be purely beta e1.6.5 thing since I tested my older save files on the beta e1.6.5 just like you.
You're welcome. Have you tried my save file tho? As I said, it might be because of my perks or my kingdom policies, so looking at my save file might help pinpoint the cause.
 

CptMuppet

Sergeant
You're welcome. Have you tried my save file tho? As I said, it might be because of my perks or my kingdom policies, so looking at my save file might help pinpoint the cause.
I just have tested it on your save file and successfuly reproduced this bug. Also I found what is causing it and reproduced it on my save files too. This is how it works. After creating or joining an army you can do this influence exploit once. If you after this disband/leave the army and then create/join any army again, this exploit's state resets and you can use it again.

Now when I am thinking about it, I am not sure, but have a vague memory in my mind that it is some older bug which just came back to life again on the beta e1.6.5.
 

Grank

Sergeant Knight at Arms
WBNWVC
This is how it works. After creating or joining an army you can do this influence exploit once. If you after this disband/leave the army and then create/join any army again, this exploit's state resets and you can use it again.
Well that's odd. In this playthrough I rarely interact with armies because I've only been walking around catching stray parties and beheading them. I have created or joined an army before in the past tho. If that's the cause then I understand. So far I've only observed used this exploit by loading and saving.

Good to hear that you found the cause. Hope it gets fixed.
 
Top Bottom