Modded Linux Mint Empires of Europe 1700

Users who are viewing this thread

Version number
1.2.9.38256
Branch
Main
Modded/unmodded
Yes, I used mods.

Wookash

Recruit
Summary: Gog version of the game installed via Lutris on Linux Mint crashes when started with Empires of Europe 1700 (with all dependencies) enabled. The core game works normally. When started only with 'Harmony' module it also works fine.
I've looked through the Lutris and the game logs, and the game log mentions something about missing dll files and not being able to verify mod dlls. Unfortunately I don't really know if this is the cause of the crash, and if it is, I don't know how to resolve that. I included the logs at the end of this post.
How to Reproduce: Extract: Harmony, Europe Map, EoE1700 Assets, EoE1700 and BannerColorPersistence mods into the 'Modules' folder in the game directory 'Games/gog/mount-blade-ii-bannerlord/drive_c/Mount & Blade II Bannerlord/Modules'. Then start the game. Then enable the mods in the 'Mods' part of the launcher. Then start the game.
Have you used cheats and if so which: Only mods.
Scene Name (if related):
Media (Screenshots & Video):
My launcher setup:


The error that shows up after starting the game:

Computer Specs:
OS: Linux Mint 21.3 Cinnamon
GPU: NVIDIA Corporation GA104 [Geforce RTX 3070 Ti Laptop GPU]
GPU Driver Version: nvidia-driver-545 Version 545.29.06-ubuntu0.22.04.2
CPU: AMD Ryzen 7 6800H with Radeon Graphics × 8
RAM: 16 GB
Motherboard: ASUSTeK COMPUTER INC. G713RW
Storage Device (HDD/SSD): Micron 2450 1,0 TB

Lutris log:


Log in the 'launcher_log_93015.txt' file:
 
We don't officially support Linux and any issues with modded games. Sadly there is not much we can offer to help. IF you can reproduce the issue without the mods installed we can maybe take a look but that does not mean we are going to support Linux.
 
We don't officially support Linux and any issues with modded games. Sadly there is not much we can offer to help. IF you can reproduce the issue without the mods installed we can maybe take a look but that does not mean we are going to support Linux.
Yeah of course I understand that. I am just looking for help everywhere I can. But do You perhaps know if this is a .dll files problem? Considering this part of the log:

Code:
Init LauncherModsDLLManager
Need to verify: BannerColorPersistence.dll
Need to verify: Bannerlord.Harmony.dll
Need to verify: E1100.dll
Need to verify: StartDatePrototype.dll
Need to verify: Europe_LemmyProject.dll
Starting verifying DLLs
Couldn't verify dlls
File not found
   at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
   at TaleWorlds.MountAndBlade.Launcher.Library.LauncherModsDLLManager.GetDLLVerifyReport(String[] dlls)

I would say it is. But I am not quite sure about that. I don't demand or expect your help with fixing my modded linux version of the game, but just looking for potential answers.

And if you please could, what would you advise if it happened on Windows?
Thanks for your help :smile:
 
If it was on Windows the first thing we would like to know if it is related to the mod you are trying to play with. So we need to see if it is reproducible on a non modded scenario so that our QA team can investigate it further.
 
Back
Top Bottom