Resolved Launcher not working

Users who are viewing this thread

Version number
1.6.1
Branch
Main
Modded/unmodded
Yes, but I removed mods.
Dump identifier (optional)
The crash tool failed to send the error.

Revolt500

Recruit
Summary: When I start the launcher it doesn't open.
Things I have tried:
1. Verifying game files
2. Deleting and reinstalling ( I also tried a clean install. )
3. Checking/Updating drivers, Windows,etc
4. Launching game from M&B Bannerlord -> bin -> Win64_shipping_client -> bannerlord ( It only worked with Bannerlord.Native file. )
5. repeated the above set trying to run in administrator ( I tried to put admin permission on both the launcher and the MB file and once again just the Bannerlord.Native file. worked )
6.
Delete files in bin and check;
Delete files in ProgramData folder and check;
Delete files in documents and check ;
Delete everything in Modules and check;
Delete everything at once, including the MB folder on Steam and check;
Delete config folder and check.


The problem displays the following message >
'' Module xml ../../Modules/SandBoxCore\SubModule.xml cant be loaded, there are some errors ''

The tool crash did not work and left the following message
> '' Cannot send the report files to server. Message: System.I.O.FileNotFoundException:Could not load file or assembly 'System.xml, Version = 4.0.0.0, Culture=Neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies the system cannot find the specified file

How to Reproduce: Click play
Have you used cheats and if so which: Never
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: GTX 1660
GPU Driver Version: 471.68
CPU: Ryzen 5 5600X
RAM: 16 GB
Motherboard: B450M DS3H
Storage Device (HDD/SSD): 500 GB SSD
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, can you please check and update your dotnet(.net) version if it is not up to date? You can try the windows 10 version.
 

Revolt500

Recruit
Hello, can you please check and update your dotnet(.net) version if it is not up to date? You can try the windows 10 version.
I forgot to mention that I had already checked dotnet, and I followed the instructions from (I believe) all the links in the crashes part of this forum, but thanks for your attention !
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, thank you for stating out. Can you please let me know the version of the dotnet version you have installed and about your windows language and keyboard region settings?
 

Revolt500

Recruit
Hello, thank you for stating out. Can you please let me know the version of the dotnet version you have installed and about your windows language and keyboard region settings?
dotnet version = 4.8

Regarding the language, both are Portuguese Brazil
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i will forward this info to our QA team for further inspection. Thank you for your time.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
It seems like your c# runtime is not able to load System.xml binary and as a result the xml files that are used by the game/crash uploader can not be red/written. Probably, this also causes your Launcher not to start up. It may be due to a .netframework/.netcore installation problem. Can you please uninstall then start a clean install with the required dotnet packages from these links ?

dotnet framework =>

https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net472-web-installer

dotnet core =>

https://dotnet.microsoft.com/download/dotnet/thank-you/runtime-2.1.30-windows-x64-installer
 

Vin Petrol

Recruit
im getting the "the feature you are trying to use is on a network that is unavailable, please select the path for vc_runtimeminimum_64.msi" error, i have tried everything i have found on forums and still getting the message on launch.
before i tried a bunch of things the message was "runtime_minimum_x64.msi" intsead
thanks
https://steamuserimages-a.akamaihd.net/ugc/1689402448872222187/1B5CFB39AD158C8E699F512636325FD0014E6E2D/?imw=5000&imh=5000&ima=fit&impolicy=Letterbox&imcolor=#000000&letterbox=false
 
Last edited:

MorosMaire

Recruit
when i launch the game the launcher shows up but after i press play nothing happens. I've restarted my pc, Uninstalled/reinstalled the game, verified the game, checked to see if i was fully updated, ran game and launcher as admin, launched game from folder, and I've tried launching the game in different versions. Nothings work
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
when i launch the game the launcher shows up but after i press play nothing happens. I've restarted my pc, Uninstalled/reinstalled the game, verified the game, checked to see if i was fully updated, ran game and launcher as admin, launched game from folder, and I've tried launching the game in different versions. Nothings work
‘Launcher not Launching’ / Game is not launching Workarounds
If you experiencing any issues with the launcher, you can try the workarounds below to fix it:
  • The first thing to do when experiencing any issue with the game is verifying the game files. After an update, there is always a chance of some of the game files being corrupted or missing. Doing this will verify that the game files are installed correctly. You can also check our guide regarding this here.
  • Deleting the configs folder of the game located in the Documents folder. Please keep in mind that this will also delete your saved options of the game. Don’t forget to back up the files if you don’t want to lose them. (C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs)
  • If you have installed a mod called Fixed Launcher in the past, you need to make sure that you have deleted its files. These files can block the launcher from launching. The files of the aforementioned mod.
  • Check your Windows Defender settings for Ransomware Protection. You should add Bannerlord to the list under the Controlled Folder Access. To do that:
  • - Open Windows Defender Security Center.
  • - Click on Virus & threat protection.
  • - Click the Virus & threat protection settings option.
  • - Under "Controlled folder access," click the Allow an app through the Controlled folder access link.
  • - Click the Add an allowed app button to add Bannerlord.
  • If none of the workarounds above helped you, you can try to launch the game via the TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder below:
  • ...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
 

MorosMaire

Recruit
‘Launcher not Launching’ / Game is not launching Workarounds
If you experiencing any issues with the launcher, you can try the workarounds below to fix it:
  • The first thing to do when experiencing any issue with the game is verifying the game files. After an update, there is always a chance of some of the game files being corrupted or missing. Doing this will verify that the game files are installed correctly. You can also check our guide regarding this here.
  • Deleting the configs folder of the game located in the Documents folder. Please keep in mind that this will also delete your saved options of the game. Don’t forget to back up the files if you don’t want to lose them. (C:\Users\user.name\Documents\Mount and Blade II Bannerlord\Configs)
  • If you have installed a mod called Fixed Launcher in the past, you need to make sure that you have deleted its files. These files can block the launcher from launching. The files of the aforementioned mod.
  • Check your Windows Defender settings for Ransomware Protection. You should add Bannerlord to the list under the Controlled Folder Access. To do that:
  • - Open Windows Defender Security Center.
  • - Click on Virus & threat protection.
  • - Click the Virus & threat protection settings option.
  • - Under "Controlled folder access," click the Allow an app through the Controlled folder access link.
  • - Click the Add an allowed app button to add Bannerlord.
  • If none of the workarounds above helped you, you can try to launch the game via the TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder below:
  • ...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client
  • Check your OneDrive folder contents. Even if it is disabled we have seen users post that their files have been changed with the previous OneDrive synced files. You should try deleting your OneDrive files. More info about that can be found here.
When i was trying everything you said nothing worked until i went to the config folder i had 3 files which where "BannerlordConfig/BannerlordGameKeys/engine_config" had and X on them, when i tried to delete them it said the place their saved is not open meaning they where in onedrive which i keep closed. The game runs now thanks for the help.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i am glad the problem is solved. Please let us know if you encounter any other issues.
 
Top Bottom