Unresolved Launcher Mod Bug/Support

Currently viewing this thread:

monoolho

Knight
M&BWBWF&SNWVC
I'm going to be straight to the point here:

Opened the launcher, went to the Mods tab, tried to click around to check/uncheck the modules checkboxes, and tried to drag the modules, just to test it out. Doing so did not move any of the modules (which was expected for now), and no checkbox showed any visual difference (which I understand why, but I expected something visual just to understand how it works, "which colour means active/inactive" or something).

However, the problem arose when I launched the game and tried to load a save: it asked if I wanted to 'load a save with different modules'. I was surprised and sort of happy that such a warning is on the game, but now I am worried I might have disabled any of the main modules from the game without even knowing it. As soon as it happened, I jumped to the forums to report it.

Quick fix suggestion: either disable deactivating modules for now, or fix the checkbox visual effect for when you actually activate/deactivate a module. For save-safety reasons, I'll try to find the launcher module settings and manually set all modules to ON if able to, as it was before. I'll check back here if anything happens, and if not, too.

To avoid doubleposting, I will proceed here: found the mod loader file under \Documents\Mount and Blade II Bannerlord\Configs\LauncherData.xml
there we find
XML:
<ModDatas>

      <UserModData>

        <Id>Native</Id>

        <IsSelected>true</IsSelected>

      </UserModData>[...]

Left everything checked as IsSelected>true<, tried to load a save, and the warning message remains. I will keep playing and see if anything is amiss and report back here.

(I had posted this on the modding forums by some mindmistake, sorry for that.)
 
Last edited:
Top Bottom