Need More Info launcher crashes on startup: System.Xml.XmlException

Users who are viewing this thread

Version number
Yes, but I removed mods.
Dump identifier (optional)
not available
Hello Guys

after a faulty windows update I had to reinstall my windows and after starting to update my drivers, mount and blade launcher stopped working. when trying to start the launcher through steam or via .exe, it will appear in the taskbar for a short time and then disappear. I tried literally anything that I found on the internet but nothing worked.
Things I tried:
-Verified Game Install
-Deleted bin, then verified
-deleted whole M&B, uninstalled, reinstalled
-updated every single driver on the system
-installed every OS update (except for the last optional)
-update Framework 3.5 and 4.8
-ran framework repair tool
-made file explorer all visible
-ran CCleaner Health check and registry repair/cleanup
-repaired both harddrives
-ran sfc/scannow
-made sure Visual C++ studios 2015 and 2017 are up to date
-repaired .net runtime
-and I don't know what else I did, was on it for like the last 3 days...

(btw, It doesn't launch on newest game version either)
So, windows logs give the following 2 error logs seemingly pointing at .NET runtime. So maybe somebody here knows what it could be

Application: TaleWorlds.MountAndBlade.Launcher.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Xml.XmlException
at System.Xml.XmlTextReaderImpl.Throw(System.Exception)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlLoader.Load(System.Xml.XmlDocument, System.Xml.XmlReader, Boolean)
at System.Xml.XmlDocument.Load(System.Xml.XmlReader)
at System.Xml.XmlDocument.Load(System.String)
at TaleWorlds.Library.NewsManager.NewsManager.UpdateConfigSettings()
at TaleWorlds.MountAndBlade.Launcher.LauncherVM..ctor(TaleWorlds.MountAndBlade.Launcher.UserDatas.UserDataManager, System.Action, System.Action)
at TaleWorlds.MountAndBlade.Launcher.LauncherUI.Initialize()
at TaleWorlds.MountAndBlade.Launcher.StandaloneUIDomain.Update()
at TaleWorlds.TwoDimension.Standalone.WindowsFramework.MainLoop(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart(System.Object)
Name der fehlerhaften Anwendung: TaleWorlds.MountAndBlade.Launcher.exe, Version:, Zeitstempel: 0x60083b10
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.19041.662, Zeitstempel: 0xec58f015
Ausnahmecode: 0xe0434352
Fehleroffset: 0x000000000002d759
ID des fehlerhaften Prozesses: 0x3da8
Startzeit der fehlerhaften Anwendung: 0x01d6fb2698f7f56f
Pfad der fehlerhaften Anwendung: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Launcher.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\KERNELBASE.dll
Berichtskennung: e5ee9167-688a-420f-ac4b-58d65466074b
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

When starting the game directly without launcher, it works as usual. But I can't use any mods and I would be very very happy to be able to play with mods again :smile:
I had it when it still worked, but not on this instance of windows. I did put in the BUTR loader though. I deleted everything and tried without it after that with same result
Top Bottom