Need More Info Launcher Bugged

Users who are viewing this thread

Version number
No, I didn't use any mods.


I've been having an issue where my launcher is bugged. I've been trying everything I can do to fix this issue. This issue has been present since I installed the game, but I have been able to play by launching the game via the direct .exe instead of the launcher. The issue itself launches the launcher, but the only visual changes are that the system says it is running, and the cursor changes for a brief moment before returning to normal. Nothing comes up to launch or change load order of the game.
What I've tried:
Verify Integrity of Game files,
Fresh Installs,
Unblocking DLLs (Unsure of this one because I've never heard of DLLs being blocked before)
Deleting BIN, then Verifying again.
Trying different builds/betas.
Checking Security/Ransomware as well as allowed apps through firewalls. As well as making sure controlled folder access is disabled.
Changing compatibility modes/ running from administrator.
Updating .NET and other frameworks/GPU updates via one of the threads on Taleworlds support and making sure everything is up to date.
I've also tried running the CrashUploader.Publish.exe but nothing runs.
I have never once installed mods, I did however try to change the config once to try and initiate cheats to go around another bug I was experiencing in-game which wasn't allowing my character's spouse to conceive children. I'd get the notification briefly she was pregnant but it wouldn't ever come to term. Then I realized I needed to install mods in order for that console command, and like I said I never installed mods. I just changed a 0 to 1 once to activate cheat mode, but that was before this fresh install.
I've also tried disabling and uninstalling OneDrive, and separating my saves, so they are not changed when I did a fresh install.
I've disabled all relevant M&B folders from read only.

I possibly tried other things but the amount of things I've tried is just got to the point where I'm having a hard time remembering them.

Also it appears I can't get the crashuploader to work. Perhaps because this is a Launcher bug/issue this doesn't run for it? Like I said previously everything else seems to run fine, the game runs, but I'd like to figure out this launcher issue so that I can have a completed experience and possibly dabble in mods in the future after my first unmodded playthrough.

I've checked the logs, and I received this crash log.

Try to load dll TaleWorlds.MountAndBlade.Launcher.Steam.dll

Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 0.9120

How to Reproduce:
Run the Mount and Blade 2 Launcher Program through Steam, or through the Launcher .exe or shortcut.
Have you used cheats and if so which: I have not used cheats, but I did activate cheat mode once. I however never activated any shortcut cheat keys. I only changed the config to say it was in cheat mode.
Computer Specs:
OS: Windows 10 64bit
GPU Driver Version:
CPU: Intel(R) Core(TM) i5-2400 CPU @ 3.10GH
RAM: 16265 MB
Baseboard Manufacturer: Dell Inc.
Baseboard Product: OHY9JP
Storage Device (HDD/SSD):
Number of SSDs: 1
SSD sizes: 256G
Number of HDDs: 1
HDD sizes: 500G

MArdA TaleWorlds

Community Support & Localization
Community Support
Could you check the windows event viewer for more information that we can use?
You can open the windows event viewer by searching eventviewer in search. You can navigate to windows logs to application and then error to find the details.


I checked the event viewer, it was actually not showing up an error on the event viewer and was acting like it was a regular application being opened and then closed, but after a bit of messing around I was able to get two errors to show up and this is what it is saying.
Application: TaleWorlds.MountAndBlade.Launcher.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException
at System.Reflection.RuntimeAssembly._nLoad(System.Reflection.AssemblyName, System.String, System.Security.Policy.Evidence, System.Reflection.RuntimeAssembly, System.Threading.StackCrawlMark ByRef, IntPtr, Boolean, Boolean, Boolean)
at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(System.Reflection.AssemblyName, System.Security.Policy.Evidence, System.Reflection.RuntimeAssembly, System.Threading.StackCrawlMark ByRef, IntPtr, Boolean, Boolean, Boolean)
at System.Reflection.RuntimeAssembly.InternalLoadFrom(System.String, System.Security.Policy.Evidence, Byte[], System.Configuration.Assemblies.AssemblyHashAlgorithm, Boolean, Boolean, System.Threading.StackCrawlMark ByRef)
at System.Reflection.Assembly.LoadFrom(System.String)
at TaleWorlds.MountAndBlade.Launcher.Program.OnAssemblyResolve(System.Object, System.ResolveEventArgs)
at System.AppDomain.OnAssemblyResolveEvent(System.Reflection.RuntimeAssembly, System.String)

Exception Info: System.IO.FileNotFoundException
at TaleWorlds.MountAndBlade.Launcher.Program.Main(System.String[])

((The source says it's from .NET Runtime for this ^^^^))

Faulting application name: TaleWorlds.MountAndBlade.Launcher.exe, version:, time stamp: 0x61d7fbad
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1387, time stamp: 0x0b9a844a
Exception code: 0xe0434352
Fault offset: 0x0000000000034f69
Faulting process id: 0x10dc
Faulting application start time: 0x01d8040a9d79ec93
Faulting application path: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Launcher.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: fc527125-443a-4f04-8fca-409d39ad29e4
Faulting package full name:
Faulting package-relative application ID:

((Source is the Application))

If there is any other information I can provide it, or send some screenshots if needed just let me know, thank you.


Can you post your
output? While "steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" is open, right click on an empty area in the windows explorer while holding shift, click "Open PowerShell window here" and type "dir", enter.


Here is what came up on the powershell.

PS D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client> dir

Directory: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client

Mode LastWriteTime Length Name
---- ------------- ------ ----
d----- 2022-01-06 5:07 PM BattlEye
d----- 2022-01-06 5:07 PM mono
-a---- 2022-01-15 12:51 PM 112072 amd_ags_x64.dll
-a---- 2022-01-15 12:51 PM 129992 Bannerlord.exe
-a---- 2022-01-15 12:51 PM 136648 Bannerlord.Native.exe
-a---- 2022-01-06 2:37 PM 837128 Bannerlord_BE.exe
-a---- 2022-01-06 2:37 PM 5235208 BEClient_x64.dll
-a---- 2022-01-15 12:51 PM 146376 CSteamworks.dll
-a---- 2022-01-06 2:37 PM 4481992 d3dcompiler_47.dll
-a---- 2022-01-06 2:37 PM 166576 dbgcore.dll
-a---- 2022-01-06 2:37 PM 1938072 dbghelp.dll
-a---- 2022-01-06 2:37 PM 12892128 EOSSDK.dll
-a---- 2022-01-15 12:51 PM 573896 Epic.OnlineServices.dll
-a---- 2022-01-15 12:51 PM 15279048 Galaxy64.dll
-a---- 2022-01-15 12:51 PM 400840 GalaxyCSharp.dll
-a---- 2022-01-15 12:51 PM 1902536 GalaxyCSharpGlue.dll
-a---- 2022-01-06 2:37 PM 4228392 GfeSDK.dll
-a---- 2022-01-15 12:51 PM 1209800 GFSDK_Aftermath_Lib.x64.dll
-a---- 2022-01-15 12:51 PM 217032 grCore.dll
-a---- 2022-01-15 12:51 PM 396232 grGranite.dll
-a---- 2022-01-15 12:51 PM 381384 grGraniteDX11.dll
-a---- 2022-01-15 12:51 PM 265160 grGraniteDX12.dll
-a---- 2022-01-15 12:51 PM 708040 grGraniteQuartzFast.dll
-a---- 2022-01-07 11:44 PM 85 imgui.ini
-a---- 2022-01-15 12:51 PM 63432 jose-jwt.dll
-a---- 2022-01-15 12:51 PM 6219208 mono-2.0-sgen.dll
-a---- 2022-01-15 12:51 PM 285128 Mono.Cecil.dll
-a---- 2022-01-15 12:51 PM 162248 MonoPosixHelper.dll
-a---- 2022-01-06 2:37 PM 1514544 msdia140.dll
-a---- 2022-01-15 12:51 PM 660936 Newtonsoft.Json.dll
-a---- 2022-01-06 2:37 PM 11887416 nvngx_dlss.dll
-a---- 2022-01-15 12:51 PM 1525192 PhysXCommon_64.dll
-a---- 2022-01-15 12:51 PM 245192 PhysXCooking_64.dll
-a---- 2022-01-06 2:37 PM 704208 PhysXDevice64.dll
-a---- 2022-01-15 12:51 PM 63944 PhysXFoundation_64.dll
-a---- 2022-01-06 2:37 PM 27009232 PhysXGpu_64.dll
-a---- 2022-01-15 12:51 PM 2038728 PhysX_64.dll
-a---- 2022-01-15 12:51 PM 239560 Steamworks.NET.dll
-a---- 2022-01-06 2:38 PM 206760 steam_api64.dll
-a---- 2022-01-07 9:12 PM 6 steam_appid.txt
-a---- 2022-01-06 2:38 PM 250008 symsrv.dll
-a---- 2022-01-06 2:37 PM 380848 System.Configuration.ConfigurationManager.dll
-a---- 2022-01-06 2:38 PM 68168 System.Management.dll
-a---- 2022-01-06 2:38 PM 163712 System.Numerics.Vectors.dll
-a---- 2022-01-06 2:37 PM 24880 System.Security.Cryptography.ProtectedData.dll
-a---- 2022-01-06 2:37 PM 94584 System.Security.Permissions.dll
-a---- 2022-01-06 2:37 PM 759544 System.Text.Encoding.CodePages.dll
-a---- 2022-01-06 2:37 PM 118520 System.Xml.XPath.XmlDocument.dll
-a---- 2022-01-15 12:51 PM 12232 TaleWorlds.AchievementSystem.dll
-a---- 2022-01-15 12:51 PM 9672 TaleWorlds.ActivitySystem.dll
-a---- 2022-01-15 12:51 PM 11720 TaleWorlds.BattlEye.Client.dll
-a---- 2022-01-15 12:51 PM 4129736 TaleWorlds.CampaignSystem.dll
-a---- 2022-01-15 12:51 PM 1160648 TaleWorlds.CampaignSystem.ViewModelCollection.dll
-a---- 2022-01-15 12:51 PM 403400 TaleWorlds.Core.dll
-a---- 2022-01-15 12:51 PM 61384 TaleWorlds.Core.ViewModelCollection.dll
-a---- 2022-01-15 12:51 PM 10696 TaleWorlds.Diamond.AccessProvider.Epic.dll
-a---- 2022-01-15 12:51 PM 9672 TaleWorlds.Diamond.AccessProvider.GDK.dll
-a---- 2022-01-15 12:51 PM 10696 TaleWorlds.Diamond.AccessProvider.GOG.dll
-a---- 2022-01-15 12:51 PM 10184 TaleWorlds.Diamond.AccessProvider.Steam.dll
-a---- 2022-01-15 12:51 PM 10184 TaleWorlds.Diamond.AccessProvider.Test.dll
-a---- 2022-01-15 12:51 PM 17352 TaleWorlds.Diamond.ChatSystem.Library.dll
-a---- 2022-01-15 12:51 PM 76232 TaleWorlds.Diamond.dll
-a---- 2022-01-15 12:51 PM 35784 TaleWorlds.DotNet.AutoGenerated.dll
-a---- 2022-01-15 12:51 PM 53704 TaleWorlds.DotNet.dll
-a---- 2022-01-15 12:51 PM 482248 TaleWorlds.Engine.AutoGenerated.dll
-a---- 2022-01-15 12:51 PM 376264 TaleWorlds.Engine.dll
-a---- 2022-01-15 12:51 PM 26568 TaleWorlds.Engine.GauntletUI.dll
-a---- 2022-01-15 12:51 PM 33736 TaleWorlds.GauntletUI.Data.dll
-a---- 2022-01-15 12:51 PM 236488 TaleWorlds.GauntletUI.dll
-a---- 2022-01-15 12:51 PM 36296 TaleWorlds.GauntletUI.ExtraWidgets.dll
-a---- 2022-01-15 12:51 PM 51144 TaleWorlds.GauntletUI.PrefabSystem.dll
-a---- 2022-01-15 12:51 PM 12232 TaleWorlds.GauntletUI.TooltipExtensions.dll
-a---- 2022-01-15 12:51 PM 49608 TaleWorlds.InputSystem.dll
-a---- 2022-01-15 12:51 PM 190408 TaleWorlds.Library.dll
-a---- 2022-01-15 12:51 PM 28104 TaleWorlds.LinQuick.dll
-a---- 2022-01-15 12:51 PM 188360 TaleWorlds.Localization.dll
-a---- 2022-01-15 12:51 PM 20936 TaleWorlds.ModuleManager.dll
-a---- 2022-01-15 12:51 PM 263624 TaleWorlds.MountAndBlade.AutoGenerated.dll
-a---- 2022-01-15 12:51 PM 247240 TaleWorlds.MountAndBlade.Diamond.dll
-a---- 2022-01-15 12:51 PM 2326984 TaleWorlds.MountAndBlade.dll
-a---- 2022-01-15 12:51 PM 84936 TaleWorlds.MountAndBlade.GauntletUI.CodeGenerator.exe
-a---- 2022-01-15 12:51 PM 561608 TaleWorlds.MountAndBlade.GauntletUI.Widgets.dll
-a---- 2022-01-15 12:51 PM 9672 TaleWorlds.MountAndBlade.Helpers.dll
-a---- 2022-01-15 12:51 PM 98248 TaleWorlds.MountAndBlade.Launcher.exe
-a---- 2022-01-15 12:51 PM 29128 TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe
-a---- 2022-01-15 12:51 PM 28616 TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe
-a---- 2022-01-15 12:51 PM 9672 TaleWorlds.MountAndBlade.Launcher.Steam.dll
-a---- 2022-01-15 12:51 PM 10696 TaleWorlds.MountAndBlade.SaveSystem.CodeGenerator.exe
-a---- 2022-01-15 12:51 PM 38344 TaleWorlds.MountAndBlade.SteamWorkshop.exe
-a---- 2022-01-15 12:51 PM 895432 TaleWorlds.MountAndBlade.ViewModelCollection.dll
-a---- 2022-01-15 12:51 PM 12989384 TaleWorlds.Native.dll
-a---- 2022-01-15 12:51 PM 7624 TaleWorlds.NavigationSystem.dll
-a---- 2022-01-15 12:51 PM 58312 TaleWorlds.Network.dll
-a---- 2022-01-15 12:51 PM 48584 TaleWorlds.ObjectSystem.dll
-a---- 2022-01-15 12:51 PM 27080 TaleWorlds.PlatformService.dll
-a---- 2022-01-15 12:51 PM 45512 TaleWorlds.PlatformService.Epic.dll
-a---- 2022-01-15 12:51 PM 36296 TaleWorlds.PlatformService.GOG.dll
-a---- 2022-01-15 12:51 PM 34760 TaleWorlds.PlatformService.Steam.dll
-a---- 2022-01-15 12:51 PM 25032 TaleWorlds.PlayerServices.dll
-a---- 2022-01-15 12:51 PM 126920 TaleWorlds.PowerText.dll
-a---- 2022-01-15 12:51 PM 85960 TaleWorlds.PSAI.dll
-a---- 2022-01-15 12:51 PM 128456 TaleWorlds.SaveSystem.dll
-a---- 2022-01-15 12:51 PM 8136 TaleWorlds.Starter.DotNetCore.dll
-a---- 2022-01-06 2:38 PM 242
-a---- 2022-01-06 2:38 PM 154 TaleWorlds.Starter.DotNetCore.Linux.runtimeconfig.json
-a---- 2022-01-15 12:51 PM 10696 TaleWorlds.Starter.Library.dll
-a---- 2022-01-15 12:51 PM 90056 TaleWorlds.TwoDimension.dll
-a---- 2022-01-15 12:51 PM 72136 TaleWorlds.TwoDimension.Standalone.dll
-a---- 2022-01-15 12:51 PM 97 Version.xml

PS D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client>


Alright so I have an update. I was able to figure out that my graphics card was not registering being used on the display I was using because it was plugged into a vga port. I can reiterate more if need be on the issue, but after using the hdmi (waiting on dvi to use the older monitor again) I was able to get the launcher to run using my actual graphics card instead of intel hd graphics. The launcher runs now but now I am actually facing a game breaking issue where I can't play. The launcher will launch and then when I hit play or continue it opens up in fullscreen and then crashes, with a crash logger type thing that opens. I click that I want to upload the crash log but it doesn't do anything beyond that and closes out the program. I could use some guidance on the issue, and ways to make the game playable again.

I tested some other games and they were working fine.

I also went in and changed my monitor back to the vga monitor and tested the game, and it ran, but the launcher still didn't. When I went to the HDMI tv, the game wouldn't run but the launcher would. A little confusing cause the game said I selected the GT1030 as my graphics driver but my display said it was only running the Intel HD.

Update: After waiting for an extra cable and it came in I got it to run from the launcher for the first time, so it appears my issue is fixed. The problem was that I was running from my vga cable (Intel HD) and my Graphics card at once. I got a DVI cable with an adapter for vga and that appears to have fixed my issue.
Last edited:


Update: After waiting for an extra cable and it came in I got it to run from the launcher for the first time, so it appears my issue is fixed. The problem was that I was running from my vga cable (Intel HD) and my Graphics card at once. I got a DVI cable with an adapter for vga and that appears to have fixed my issue.
Are you still crashing on initial load?


No not crashing anymore. Everything seems to be running fine now. I was able to get the game running from the launcher and then even went into a few battles just to test performance. I only ran it about 2-3 times but I'd say that is consistent enough for me to say it's fixed.
Top Bottom