Laggy menus

Currently viewing this thread:

chibirobo

Regular
Hello, I'm coming back from a break, and I've noticed that my menus are laggy like when I click I to open my inventory screen it will lag a bit and then open. same thing with every menu. I've uninstalled the game and reinstalled but I'm still getting this problem. Do any of you know of a fix? I'm playing on 1.5.9 I've made sure my drivers are up to date. I also have no mods as well. I didn't have this issue with 1.5.5. Thank you in advance.
 

Bratok

Recruit
Same here. Even on 970 Evo Plus NVMe SSD all menus have a noticeable lag when opening and closing them.
 

Dreed89

Sergeant at Arms
I have the same problem with good-enough pc as well.

Patch notes claimed they fixed it but it is still worse than it was used to be before.
 

Aurex

Regular
WB
Tried on two systems, one is a monster machine, the other is better than the recommended system: in both cases installed on an SSD.
There's some kind of lag in every single menu which changes "scenes" (from map to inventory, from map to character screen, from conversation screen to map... and so on) that I suspect is due to memory leaks.
It's still there after like a month and a half. The fact the patch notes say it's been fixed is an almost literal kick in the nuts.
 

Cleo

Regular
same here . havent played in months . and i remember for sure this wasnt the case before
there is lag on button click on any menu ( like 1-2 seconds )
 

Dreed89

Sergeant at Arms
Submitting telemetry data (steps are in this post https://forums.taleworlds.com/index.php?threads/beta-branch-with-telemetry-tools.423365/) would help greatly resolving this issue. A video would also be appreciated, but telemetry would be the most helpful.
Hey @emrozdemir , back then I had created this support ticket. It was for 1.5.7 but the problem still exists. All the details including telemetry tools submission is there. Please note that on HDD these lags are more visible.

 
This was indeed fixed some patch ago, not sure wich patch, maybe 1.5.8? but it is really back now, i will use the telemtry tools and send the file to TW
 

MRay

Developer
Hey @emrozdemir , back then I had created this support ticket. It was for 1.5.7 but the problem still exists. All the details including telemetry tools submission is there. Please note that on HDD these lags are more visible.

Can you submit a new telemetry again in 1.5.9 if it's not too much trouble? Thank you.
This was indeed fixed some patch ago, not sure wich patch, maybe 1.5.8? but it is really back now, i will use the telemtry tools and send the file to TW
Thank you I'll personally take a look at it.
 
Can you submit a new telemetry again in 1.5.9 if it's not too much trouble? Thank you.

Thank you I'll personally take a look at it.
I moved to the telemetry branch and suddenly all my performance issues (UI and Battle related) were gone, then i rolled back to the main branch and the issues are still gone. Everything is working fine now :unsure:
 
Did you turn on cheat mode? Cheat mode will permit access to a cheat inventory on left-hand side of screen when you open your inventory directly(by directly I mean not when talking to a merchant), that cheat inventory is extremly lengthy and require much more time to load
 
Top Bottom